aboutsummaryrefslogtreecommitdiffstats
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-08-21 00:28:17 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-10-01 11:26:23 +0800
commit0d0654c19f7d966110cebed882b6a6e80f5e4198 (patch)
treea5aaa8636f4cb85eb0c502ada907eb2e5a05e098 /modules/Makefile.am
parentb46da7735a5f58c3477f7725d88f4374a9c5dd84 (diff)
downloadgsoc2013-evolution-0d0654c19f7d966110cebed882b6a6e80f5e4198.tar
gsoc2013-evolution-0d0654c19f7d966110cebed882b6a6e80f5e4198.tar.gz
gsoc2013-evolution-0d0654c19f7d966110cebed882b6a6e80f5e4198.tar.bz2
gsoc2013-evolution-0d0654c19f7d966110cebed882b6a6e80f5e4198.tar.lz
gsoc2013-evolution-0d0654c19f7d966110cebed882b6a6e80f5e4198.tar.xz
gsoc2013-evolution-0d0654c19f7d966110cebed882b6a6e80f5e4198.tar.zst
gsoc2013-evolution-0d0654c19f7d966110cebed882b6a6e80f5e4198.zip
Check for SpamAssassin during configure.
If the spamassassin and sa-learn programs cannot be found with AC_PATH_PROG, configure will abort with an error message. You can then either: a) install the SpamAssassin software b) specify the path with SPAMASSASSIN=/path/to/spamassassin and/or SA_LEARN=/path/to/sa-learn c) pass --disable-spamassassin to configure to exclude the module This also drops the "spamc" and "spamd" GSettings keys.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index b2ec916038..a7e34de52b 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -14,6 +14,10 @@ if ENABLE_ONLINE_ACCOUNTS
ONLINE_ACCOUNTS_DIR = online-accounts
endif
+if ENABLE_SPAMASSASSIN
+SPAMASSASSIN_DIR = spamassassin
+endif
+
if ENABLE_TNEF
TNEF_ATTACHMENT_DIR = tnef-attachment
endif
@@ -47,13 +51,13 @@ SUBDIRS = \
plugin-lib \
plugin-manager \
prefer-plain \
- spamassassin \
startup-wizard \
text-highlight \
vcard-inline \
web-inspector \
$(BOGOFILTER_DIR) \
$(ONLINE_ACCOUNTS_DIR) \
+ $(SPAMASSASSIN_DIR) \
$(TNEF_ATTACHMENT_DIR) \
$(AUDIO_INLINE_DIR)