aboutsummaryrefslogtreecommitdiffstats
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-08-20 22:13:57 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-10-01 11:26:23 +0800
commitb46da7735a5f58c3477f7725d88f4374a9c5dd84 (patch)
tree6762f84154641f82408f461aa532720c1f9a20ec /modules/Makefile.am
parent5c4a1dbf39b5c3717e080833c4f887660dc1aefa (diff)
downloadgsoc2013-evolution-b46da7735a5f58c3477f7725d88f4374a9c5dd84.tar
gsoc2013-evolution-b46da7735a5f58c3477f7725d88f4374a9c5dd84.tar.gz
gsoc2013-evolution-b46da7735a5f58c3477f7725d88f4374a9c5dd84.tar.bz2
gsoc2013-evolution-b46da7735a5f58c3477f7725d88f4374a9c5dd84.tar.lz
gsoc2013-evolution-b46da7735a5f58c3477f7725d88f4374a9c5dd84.tar.xz
gsoc2013-evolution-b46da7735a5f58c3477f7725d88f4374a9c5dd84.tar.zst
gsoc2013-evolution-b46da7735a5f58c3477f7725d88f4374a9c5dd84.zip
Check for Bogofilter during configure.
If the bogofilter program cannot be found with AC_PATH_PROG, configure will abort with an error message. You can then either: a) install the Bogofilter software b) specify the path with BOGOFILTER=/path/to/bogofilter c) pass --disable-bogofilter to configure to exclude the module
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 227f9d165d..b2ec916038 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -1,3 +1,7 @@
+if ENABLE_BOGOFILTER
+BOGOFILTER_DIR = bogofilter
+endif
+
if ENABLE_LDAP
CONFIG_LDAP_DIR = book-config-ldap
endif
@@ -20,7 +24,6 @@ endif
SUBDIRS = \
addressbook \
- bogofilter \
calendar \
mail \
backup-restore \
@@ -49,6 +52,7 @@ SUBDIRS = \
text-highlight \
vcard-inline \
web-inspector \
+ $(BOGOFILTER_DIR) \
$(ONLINE_ACCOUNTS_DIR) \
$(TNEF_ATTACHMENT_DIR) \
$(AUDIO_INLINE_DIR)