aboutsummaryrefslogtreecommitdiffstats
path: root/modules/plugin-manager/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'modules/plugin-manager/Makefile.am')
-rw-r--r--modules/plugin-manager/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/plugin-manager/Makefile.am b/modules/plugin-manager/Makefile.am
new file mode 100644
index 0000000000..b84b58cb63
--- /dev/null
+++ b/modules/plugin-manager/Makefile.am
@@ -0,0 +1,21 @@
+module_LTLIBRARIES = libevolution-module-plugin-manager.la
+
+libevolution_module_plugin_manager_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-plugin-manager\" \
+ $(GNOME_PLATFORM_CFLAGS)
+
+libevolution_module_plugin_manager_la_SOURCES = \
+ evolution-plugin-manager.c
+
+libevolution_module_plugin_manager_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(GNOME_PLATFORM_LIBS)
+
+libevolution_module_plugin_manager_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk