aboutsummaryrefslogtreecommitdiffstats
path: root/modules/plugin-manager/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-09-12 07:37:37 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-09-13 20:28:59 +0800
commitc23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd (patch)
tree32f1892d63f900693638774a73fb492819fb6e94 /modules/plugin-manager/Makefile.am
parentcd53ba990035bdb4861d9660917d457533d4ecb2 (diff)
downloadgsoc2013-evolution-c23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd.tar
gsoc2013-evolution-c23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd.tar.gz
gsoc2013-evolution-c23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd.tar.bz2
gsoc2013-evolution-c23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd.tar.lz
gsoc2013-evolution-c23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd.tar.xz
gsoc2013-evolution-c23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd.tar.zst
gsoc2013-evolution-c23de2688ea9d1afa4559b9cb9e0ef4d9edeacfd.zip
Convert plugin-manager to an EExtension.
How ironic.
Diffstat (limited to 'modules/plugin-manager/Makefile.am')
-rw-r--r--modules/plugin-manager/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/plugin-manager/Makefile.am b/modules/plugin-manager/Makefile.am
new file mode 100644
index 0000000000..b84b58cb63
--- /dev/null
+++ b/modules/plugin-manager/Makefile.am
@@ -0,0 +1,21 @@
+module_LTLIBRARIES = libevolution-module-plugin-manager.la
+
+libevolution_module_plugin_manager_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-plugin-manager\" \
+ $(GNOME_PLATFORM_CFLAGS)
+
+libevolution_module_plugin_manager_la_SOURCES = \
+ evolution-plugin-manager.c
+
+libevolution_module_plugin_manager_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(GNOME_PLATFORM_LIBS)
+
+libevolution_module_plugin_manager_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk