aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/gui/Makefile.am
diff options
context:
space:
mode:
authorFederico Mena Quintero <federico@ximian.com>2001-06-25 06:53:14 +0800
committerFederico Mena Quintero <federico@src.gnome.org>2001-06-25 06:53:14 +0800
commit2c1887f5fed391efb16a1f5084a5a9016bd73f32 (patch)
tree9a80f1a619a759667b95ec2f3e642200417e4911 /calendar/gui/Makefile.am
parent1965d493f225953fd8b8b7fbcee599c5fd78b8bf (diff)
downloadgsoc2013-evolution-2c1887f5fed391efb16a1f5084a5a9016bd73f32.tar
gsoc2013-evolution-2c1887f5fed391efb16a1f5084a5a9016bd73f32.tar.gz
gsoc2013-evolution-2c1887f5fed391efb16a1f5084a5a9016bd73f32.tar.bz2
gsoc2013-evolution-2c1887f5fed391efb16a1f5084a5a9016bd73f32.tar.lz
gsoc2013-evolution-2c1887f5fed391efb16a1f5084a5a9016bd73f32.tar.xz
gsoc2013-evolution-2c1887f5fed391efb16a1f5084a5a9016bd73f32.tar.zst
gsoc2013-evolution-2c1887f5fed391efb16a1f5084a5a9016bd73f32.zip
Converted to use BonoboXObject.
2001-06-24 Federico Mena Quintero <federico@ximian.com> * gui/alarm-notify/alarm-notify.c: Converted to use BonoboXObject. * gui/gnome-cal.c (gnome_calendar_open): Ask the alarm notification service to add the calendar and tasks URIs. (add_alarms): New function. * gui/alarm-notify/notify-main.c (main): Doh, fixed typo in the OAFIID. (main): Initialize and shut down gnome-vfs. * gui/Makefile.am (IDLS): Added evolution-calendar.idl, sigh. (evolution_calendar_SOURCES): Added the files generated from the IDL. * gui/alarm-notify/alarm-queue.c (alarm_trigger_cb): New function used when an alarm is triggered. * gui/dialogs/Makefile.am: Removed the alarm-notify-dialog files; they are now in gui/alarm-notify. * gui/alarm-notify/Makefile.am: Added the alarm-notify-dialog files. * pcs/cal.c (cal_forget_password): This was incorrectly named cal_client_forget_password(); renamed it. * gui/main.c (main): Initialize and shut down gnome-vfs. svn path=/trunk/; revision=10453
Diffstat (limited to 'calendar/gui/Makefile.am')
-rw-r--r--calendar/gui/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/calendar/gui/Makefile.am b/calendar/gui/Makefile.am
index b801ca42a3..e3ec865d98 100644
--- a/calendar/gui/Makefile.am
+++ b/calendar/gui/Makefile.am
@@ -1,8 +1,9 @@
## CORBA stuff
-IDLS = \
- $(top_srcdir)/composer/Evolution-Composer.idl \
- $(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl
+IDLS = \
+ $(top_srcdir)/composer/Evolution-Composer.idl \
+ $(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl \
+ $(top_srcdir)/calendar/idl/evolution-calendar.idl
IDL_GENERATED = \
Evolution-Composer.h \
@@ -12,13 +13,19 @@ IDL_GENERATED = \
Evolution-Addressbook-SelectNames.h \
Evolution-Addressbook-SelectNames-common.c \
Evolution-Addressbook-SelectNames-skels.c \
- Evolution-Addressbook-SelectNames-stubs.c
+ Evolution-Addressbook-SelectNames-stubs.c \
+ evolution-calendar.h \
+ evolution-calendar-common.c \
+ evolution-calendar-skels.c \
+ evolution-calendar-stubs.c
-$(IDL_GENERATED): $(IDLS)
+$(IDL_GENERATED): $(IDLS)
$(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
$(srcdir)/../../composer/Evolution-Composer.idl
$(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
$(top_srcdir)/addressbook/gui/component/select-names/Evolution-Addressbook-SelectNames.idl
+ $(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
+ $(top_srcdir)/calendar/idl/evolution-calendar.idl
SUBDIRS = alarm-notify dialogs