summaryrefslogtreecommitdiffstats
path: root/hw4/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw4/Makefile.am')
-rw-r--r--hw4/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/hw4/Makefile.am b/hw4/Makefile.am
index d43b80d..d76675e 100644
--- a/hw4/Makefile.am
+++ b/hw4/Makefile.am
@@ -1,4 +1,4 @@
-EXTRA_DIST = cgiprog/kill_myself cgiprog/close_pipe
+EXTRA_DIST = cgiprog/kill_myself cgiprog/close_pipe cgiprog/very_slow README.txt
NULL =
MY_V_LN = $(MY_V_LN_@AM_V@)
@@ -61,3 +61,14 @@ all-local: $(abs_top_builddir)/info
$(abs_top_builddir)/info: $(abs_top_builddir)/server_info
$(MY_V_LN)ln -s server_info $(abs_top_builddir)/info
CLEANFILES = info kill_myself close_pipe very_slow
+
+# Workaround for SP homwork
+submit_tarball_name=SPHW4_b01902062.tar.gz
+submit_dir_name=b01902062
+
+submit: $(submit_tarball_name)
+$(submit_tarball_name): $(PACKAGE)-$(VERSION).tar.gz
+ tar -zxf $(PACKAGE)-$(VERSION).tar.gz
+ mv $(PACKAGE)-$(VERSION) $(submit_dir_name)
+ tar -zcf $(submit_tarball_name) $(submit_dir_name)
+ rm -rf $(submit_dir_name)