summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorpiaip <piaip@63ad8ddf-47c3-0310-b6dd-a9e9d9715204>2005-09-10 14:24:56 +0800
committerpiaip <piaip@63ad8ddf-47c3-0310-b6dd-a9e9d9715204>2005-09-10 14:24:56 +0800
commitfa5b233767ca9d4e012839c28eb13628d2ebba63 (patch)
treeb9f02d70672704dc7ea5726bc2d7e982c4d75dd9 /configure.in
parentf1803b4bcb86f3362dda2feba438056363faeed5 (diff)
downloadpttbbs-fa5b233767ca9d4e012839c28eb13628d2ebba63.tar
pttbbs-fa5b233767ca9d4e012839c28eb13628d2ebba63.tar.gz
pttbbs-fa5b233767ca9d4e012839c28eb13628d2ebba63.tar.bz2
pttbbs-fa5b233767ca9d4e012839c28eb13628d2ebba63.tar.lz
pttbbs-fa5b233767ca9d4e012839c28eb13628d2ebba63.tar.xz
pttbbs-fa5b233767ca9d4e012839c28eb13628d2ebba63.tar.zst
pttbbs-fa5b233767ca9d4e012839c28eb13628d2ebba63.zip
Automake is a hard work, still not working now.
git-svn-id: http://opensvn.csie.org/pttbbs/branches/piaip.automake@3152 63ad8ddf-47c3-0310-b6dd-a9e9d9715204
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in58
1 files changed, 58 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 00000000..a1721948
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,58 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(PTTBBS, 1.9, piaip@csie.ntu.edu.tw)
+AM_INIT_AUTOMAKE
+AC_CONFIG_SRCDIR(mbbsd/bbs.c)
+AC_CONFIG_HEADER(config.h)
+AC_PREFIX_DEFAULT(/home/bbs)
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_FUNC_ALLOCA
+AC_HEADER_DIRENT
+AC_HEADER_STDC
+AC_HEADER_SYS_WAIT
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h limits.h malloc.h memory.h netdb.h netinet/in.h sgtty.h stddef.h stdlib.h string.h strings.h sys/file.h sys/ioctl.h sys/param.h sys/socket.h sys/time.h syslog.h termios.h unistd.h utime.h utmp.h utmpx.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_TYPE_UID_T
+AC_C_INLINE
+AC_TYPE_OFF_T
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+AC_HEADER_TIME
+AC_STRUCT_TM
+
+# Checks for library functions.
+AC_FUNC_CLOSEDIR_VOID
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_FORK
+AC_FUNC_GETGROUPS
+# AC_FUNC_GETLOADAVG
+AC_PROG_GCC_TRADITIONAL
+AC_FUNC_LSTAT
+AC_FUNC_LSTAT_FOLLOWS_SLASHED_SYMLINK
+AC_FUNC_MALLOC
+AC_FUNC_MEMCMP
+AC_FUNC_MKTIME
+AC_FUNC_MMAP
+AC_FUNC_REALLOC
+AC_FUNC_SELECT_ARGTYPES
+AC_FUNC_SETPGRP
+AC_FUNC_SETVBUF_REVERSED
+AC_TYPE_SIGNAL
+AC_FUNC_STAT
+AC_FUNC_STRFTIME
+AC_FUNC_UTIME_NULL
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS([alarm bzero dup2 floor ftruncate getcwd gethostbyaddr gethostbyname gethostname getpagesize gettimeofday inet_ntoa localtime_r memchr memmove memset mkdir munmap pow putenv rmdir select setenv socket strcasecmp strchr strdup strerror strncasecmp strrchr strspn strstr tzset utime])
+AC_CONFIG_FILES([Makefile mbbsd/Makefile util/Makefile])
+AC_OUTPUT