aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..343a8c9
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,25 @@
+AC_INIT([nfcollect], [1.0])
+
+# Safety checks in case user overwritten --srcdir
+AC_CONFIG_SRCDIR([main.c])
+
+# Store the auxiliary build tools (e.g., install-sh, config.sub, config.guess)
+# in this dir (build-aux)
+AC_CONFIG_AUX_DIR([build-aux])
+
+# Init automake, and specify this program use relaxed structures.
+# i.e. this program doesn't follow the gnu coding standards, and doesn't have
+# ChangeLog, COPYING, AUTHORS, INSTALL, README etc. files.
+AM_INIT_AUTOMAKE([-Wall -Werror foreign dist-xz])
+
+AC_PROG_CC
+
+AC_CHECK_HEADERS(libnetfilter_log/libnetfilter_log.h)
+AC_SEARCH_LIBS(nflog_open, netfilter_log)
+
+AC_CHECK_HEADERS(pthread.h)
+AC_SEARCH_LIBS(pthread_create, pthread)
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT