aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-remote/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mail-remote/Makefile.am')
-rw-r--r--plugins/mail-remote/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/plugins/mail-remote/Makefile.am b/plugins/mail-remote/Makefile.am
new file mode 100644
index 0000000000..25653f666b
--- /dev/null
+++ b/plugins/mail-remote/Makefile.am
@@ -0,0 +1,35 @@
+
+
+# mail idl
+
+IDL = Evolution-DataServer-Mail.idl
+
+IDL_GENERATED_H = \
+ Evolution-DataServer-Mail.h
+
+IDL_GENERATED_C = \
+ Evolution-DataServer-Mail-common.c \
+ Evolution-DataServer-Mail-skels.c \
+ Evolution-DataServer-Mail-stubs.c
+
+$(IDL_GENERATED_H) $(IDL_GENERATED_C): $(IDL)
+ $(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl $(IDL_INCLUDES) $^
+
+# installed idls
+
+idl_DATA = $(IDL)
+
+_SOURCES = \
+ $(IDL_GENERATED_C) \
+ $(IDL_GENERATED_H) \
+ evolution-mail-folder.c \
+ evolution-mail-folder.h \
+ evolution-mail-session.c \
+ evolution-mail-session.h \
+ evolution-mail-store.c \
+ evolution-mail-store.h
+
+EXTRA_DIST = \
+ $(IDL)
+
+BUILT_SOURCES = $(IDL_GENERATED_H) $(IDL_GENERATED_C)