aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/exchange-operations/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/exchange-operations/Makefile.am')
-rw-r--r--plugins/exchange-operations/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/plugins/exchange-operations/Makefile.am b/plugins/exchange-operations/Makefile.am
new file mode 100644
index 0000000000..d72261e4d2
--- /dev/null
+++ b/plugins/exchange-operations/Makefile.am
@@ -0,0 +1,37 @@
+INCLUDES = -I . \
+ -I$(top_srcdir) \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(CAMEL_EXCHANGE_CFLAGS) \
+ $(CAMEL_CFLAGS) \
+ $(LDAP_CFLAGS) \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DCONNECTOR_GLADEDIR=\""$(gladedir)"\"
+
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = org-gnome-exchange-operations.eplug
+plugin_LTLIBRARIES = liborg-gnome-exchange-operations.la
+
+liborg_gnome_exchange_operations_la_SOURCES = \
+ exchange-operations.c \
+ exchange-config-listener.c \
+ exchange-account-setup.c
+
+liborg_gnome_exchange_operations_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(CAMEL_LIBS) \
+ $(CAMEL_EXCHANGE_LIBS)
+
+liborg_gnome_exchange_operations_la_LDFLAGS = -module -avoid-version
+
+glade_DATA = \
+ exchange-change-password.glade \
+ exchange-delegates.glade \
+ exchange-folder-tree.glade
+
+EXTRA_DIST = \
+ org-gnome-exchange-operations.eplug.in \
+ $(glade_DATA)
+