aboutsummaryrefslogtreecommitdiffstats
path: root/macros/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'macros/Makefile.am')
-rw-r--r--macros/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/macros/Makefile.am b/macros/Makefile.am
index d2969a8305..8dabbbcc12 100644
--- a/macros/Makefile.am
+++ b/macros/Makefile.am
@@ -1,2 +1,9 @@
-EXTRA_DIST=aclocal-include.m4 \
- gnome.m4 gnome-x-checks.m4
+## Please update this variable if any new macros are created
+MACROS= aclocal-include.m4 gnome-guile-checks.m4 \
+ gnome-objc-checks.m4 gnome-x-checks.m4 gnome.m4
+
+EXTRA_DIST=$(MACROS)
+MAINTAINERCLEANFILES=macros.dep
+
+@MAINT@macros.dep: Makefile.am
+@MAINT@ @echo "$$(top_srcdir)/aclocal.m4: $(MACROS:%=macros/%)" > $@