aboutsummaryrefslogtreecommitdiffstats
path: root/libwombat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libwombat/Makefile.am')
-rw-r--r--libwombat/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/libwombat/Makefile.am b/libwombat/Makefile.am
new file mode 100644
index 0000000000..5731584704
--- /dev/null
+++ b/libwombat/Makefile.am
@@ -0,0 +1,24 @@
+# CORBA stuff
+
+IDLS = $(top_builddir)/wombat/wombat.idl
+IDL_GENERATED = \
+ wombat.h \
+ wombat-common.c \
+ wombat-skels.c \
+ wombat-stubs.c
+
+$(IDL_GENERATED): $(IDLS)
+ $(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl `$(GNOME_CONFIG) --cflags idl` \
+ $(top_builddir)/wombat/wombat.idl
+
+# Wombat library
+lib_LTLIBRARIES = libwombat.la
+
+wombatincludedir = $(includedir)/evolution/wombat
+wombatinclude_HEADERS = \
+ wombat-client.h
+
+libwombat_la_SOURCES = \
+ $(IDL_GENERATED) \
+ wombat-client.c \
+ $(wombatinclude_HEADERS)