aboutsummaryrefslogtreecommitdiffstats
path: root/em-format/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'em-format/Makefile.am')
-rw-r--r--em-format/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/em-format/Makefile.am b/em-format/Makefile.am
new file mode 100644
index 0000000000..953364482f
--- /dev/null
+++ b/em-format/Makefile.am
@@ -0,0 +1,28 @@
+emformatincludedir = $(privincludedir)/em-format
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ $(EVOLUTION_MAIL_CFLAGS)
+
+privsolib_LTLIBRARIES = libemformat.la
+
+emformatinclude_HEADERS = \
+ em-format.h \
+ em-format-quote.h \
+ em-stripsig-filter.h
+
+libemformat_la_SOURCES = \
+ $(emformatinclude_HEADERS) \
+ em-format.c \
+ em-format-quote.c \
+ em-stripsig-filter.c
+
+libemformat_la_LDFLAGS = $(NO_UNDEFINED)
+
+libemformat_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(EVOLUTION_MAIL_LIBS)
+
+-include $(top_srcdir)/git.mk