aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 2fd7b68e18..6050a8b049 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -53,19 +53,22 @@ libeutil_la_LIBADD = $(UNICODE_LIBS)
libeutil_static_la_SOURCES = $(libeutil_la_SOURCES)
libeutil_static_la_LDFLAGS = --all-static
+pilot_sources = \
+ e-pilot-map.c \
+ e-pilot-map.h \
+ e-pilot-util.c \
+ e-pilot-util.h
+
if ENABLE_PILOT_CONDUITS
-pl_needed = e-pilot-util.c e-pilot-util.h
+pilot_compile = $(pilot_sources)
else
-pl_needed =
+pilot_compile =
endif
-libeconduit_la_SOURCES = \
- e-pilot-map.c \
- e-pilot-map.h \
- $(pl_needed)
+libeconduit_la_SOURCES = $(pilot_compile)
libeconduit_static_la_SOURCES = $(libeconduit_la_SOURCES)
libeconduit_static_la_LDFLAGS = --all-static
-
+EXTRA_DIST = $(pilot_sources)