aboutsummaryrefslogtreecommitdiffstats
path: root/doc/reference/libeshell/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/reference/libeshell/Makefile.am')
-rw-r--r--doc/reference/libeshell/Makefile.am80
1 files changed, 80 insertions, 0 deletions
diff --git a/doc/reference/libeshell/Makefile.am b/doc/reference/libeshell/Makefile.am
new file mode 100644
index 0000000000..7262075b74
--- /dev/null
+++ b/doc/reference/libeshell/Makefile.am
@@ -0,0 +1,80 @@
+# The name of the module, e.g. 'glib'.
+DOC_MODULE=libeshell
+
+# The top-level SGML file. You can change this if you want to.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting the functions and macros.
+# e.g. DOC_SOURCE_DIR=../../../gtk
+DOC_SOURCE_DIR=../../../shell
+
+# Extra options to pass to gtkdoc-scangobj. Not normally needed.
+SCANGOBJ_OPTIONS=
+
+# Extra options to supply to gtkdoc-scan.
+# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
+SCAN_OPTIONS=
+
+# Extra options to supply to gtkdoc-mkdb.
+MKDB_OPTIONS=--sgml-mode --output-format=xml --name-space=e
+
+# Extra options to supply to gtkdoc-mktmpl
+# e.g. MKTMPL_OPTIONS=--only-section-tmpl
+MKTMPL_OPTIONS=
+
+# Extra options to supply to gtkdoc-fixref. Not normally needed.
+# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
+FIXXREF_OPTIONS=
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+HFILE_GLOB=$(top_srcdir)/shell/*.h
+CFILE_GLOB=$(top_srcdir)/shell/*.c
+
+# Header files to ignore when scanning.
+IGNORE_HFILES= \
+ evo-version.h \
+ e-shell-window-private.h \
+ es-event.h
+
+# Images to copy into HTML directory.
+HTML_IMAGES=
+
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
+content_files=
+
+# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
+# These files must be listed here *and* in content_files
+expand_content_files=
+
+# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
+# Only needed if you are using gtkdoc-scangobj to dynamically query widget
+# signals and properties.
+GTKDOC_CFLAGS= \
+ -I$(top_builddir) \
+ -I$(top_srcdir) \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GTKHTML_CFLAGS)
+GTKDOC_LIBS= \
+ $(top_builddir)/libemail-engine/libemail-engine.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GTKHTML_LIBS)
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+# e.g. EXTRA_DIST += version.xml.in
+EXTRA_DIST +=
+
+# Files not to distribute
+# for --rebuild-types in $(SCAN_OPTIONS), e.g. $(DOC_MODULE).types
+# for --rebuild-sections in $(SCAN_OPTIONS) e.g. $(DOC_MODULE)-sections.txt
+#DISTCLEANFILES +=
+
+#TESTS = $(GTKDOC_CHECK)
+
+-include $(top_srcdir)/git.mk