aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 41 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 0bd89407b2..7beb9f6b46 100644
--- a/configure.in
+++ b/configure.in
@@ -568,6 +568,30 @@ fi
AC_MSG_RESULT($with_broken_spool)
+dnl ***************************************************************
+dnl Whether to build shlib components (instead of out-of-proc ones)
+dnl ***************************************************************
+
+AC_ARG_ENABLE(shlib-components,
+ [ --enable-shlib-components Enable building of some of the components as shared libs],
+ enable_shlib_components=yes,enable_shlib_components=no)
+
+AM_CONDITIONAL(ENABLE_SHLIB_COMPONENTS, test "x$enable_shlib_components" = "xyes")
+
+if test "x$enable_shlib_components" = "xyes" ; then
+ OAF_SHLIB_TYPE="shlib"
+ OAF_SHLIB_PREFIX="lib"
+ OAF_SHLIB_SUFFIX=".so"
+else
+ OAF_SHLIB_TYPE="exe"
+ OAF_SHLIB_PREFIX=""
+ OAF_SHLIB_SUFFIX=""
+fi
+
+AC_SUBST(OAF_SHLIB_TYPE)
+AC_SUBST(OAF_SHLIB_PREFIX)
+AC_SUBST(OAF_SHLIB_SUFFIX)
+
dnl ***************
dnl GNOME Libraries
dnl ***************
@@ -1235,6 +1259,8 @@ widgets/e-timezone-dialog/Makefile
widgets/menus/Makefile
widgets/misc/Makefile
wombat/Makefile
+
+my-evolution/GNOME_Evolution_Summary.oaf.in
])
if test "x$with_sub_version" != "x"; then
@@ -1258,16 +1284,26 @@ echo "\
SSL support: $msg_ssl
Dot Locking: $msg_dot
File Locking: $msg_file
- Gtk-doc: $enable_gtk_doc"
+ Gtk-doc: $enable_gtk_doc
+ Shlib components: $enable_shlib_components"
if test x$enable_gtk_doc = xyes; then
echo "
- Programming documentation files will be built automatically.
-"
+ Programming documentation files will be built automatically."
else
echo "
Programming documentation files will not be built.
You may want to install the gtk-doc package
- so that you will get the Evolution Developer's Guide.
-"
+ so that you will get the Evolution Developer's Guide."
fi
+
+if test "x$enable_shlib_components" = "xyes" ; then
+ echo "
+ *** Warning, shlib components are currently broken.
+ *** Enabling this option will probably cause Evolution to not
+ *** work correctly.
+"
+else
+ echo "
+"
+fi \ No newline at end of file