aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/smtp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camel/providers/smtp/Makefile.am')
-rw-r--r--camel/providers/smtp/Makefile.am18
1 files changed, 4 insertions, 14 deletions
diff --git a/camel/providers/smtp/Makefile.am b/camel/providers/smtp/Makefile.am
index b6bba766d6..29dc3dc44d 100644
--- a/camel/providers/smtp/Makefile.am
+++ b/camel/providers/smtp/Makefile.am
@@ -1,35 +1,25 @@
## Process this file with automake to produce Makefile.in
-libcamelsmtpincludedir = $(privincludedir)/camel
-
camel_provider_LTLIBRARIES = libcamelsmtp.la
camel_provider_DATA = libcamelsmtp.urls
INCLUDES = \
- -I.. \
- -I$(srcdir)/.. \
- -I$(srcdir)/../../.. \
+ -I$(top_srcdir) \
-I$(top_srcdir)/intl \
-I$(top_srcdir)/camel \
- -I$(top_srcdir)/e-util \
$(CAMEL_CFLAGS) \
- $(GNOME_INCLUDEDIR) \
- $(GTK_INCLUDEDIR) \
- $(NSPR_CFLAGS) \
- $(NSS_CFLAGS) \
- $(OPENSSL_CFLAGS) \
-DG_LOG_DOMAIN=\"camel-smtp-provider\"
libcamelsmtp_la_SOURCES = \
camel-smtp-provider.c \
camel-smtp-transport.c
-libcamelsmtpinclude_HEADERS = \
+noinst_HEADERS = \
camel-smtp-transport.h
-
libcamelsmtp_la_LDFLAGS = -avoid-version -module
-libcamelsmtp_la_LIBADD = $(top_builddir)/e-util/libeutil.la
+libcamelsmtp_la_LIBADD = \
+ $(top_builddir)/libedataserver/libedataserver-${BASE_VERSION}.la
EXTRA_DIST = libcamelsmtp.urls