aboutsummaryrefslogtreecommitdiffstats
path: root/camel/providers/pop3/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'camel/providers/pop3/Makefile.am')
-rw-r--r--camel/providers/pop3/Makefile.am15
1 files changed, 4 insertions, 11 deletions
diff --git a/camel/providers/pop3/Makefile.am b/camel/providers/pop3/Makefile.am
index 84f5477f97..49df41e230 100644
--- a/camel/providers/pop3/Makefile.am
+++ b/camel/providers/pop3/Makefile.am
@@ -1,20 +1,13 @@
## Process this file with automake to produce Makefile.in
-libcamelpop3includedir = $(privincludedir)/camel
-
camel_provider_LTLIBRARIES = libcamelpop3.la
camel_provider_DATA = libcamelpop3.urls
INCLUDES = \
- -I.. \
- -I$(srcdir)/.. \
- -I$(srcdir)/../../.. \
+ -I$(top_srcdir) \
-I$(top_srcdir)/intl \
-I$(top_srcdir)/camel \
- -I$(top_srcdir)/e-util \
$(CAMEL_CFLAGS) \
- $(GNOME_INCLUDEDIR) \
- $(GTK_INCLUDEDIR) \
-DG_LOG_DOMAIN=\"camel-pop3-provider\"
libcamelpop3_la_SOURCES = \
@@ -24,15 +17,15 @@ libcamelpop3_la_SOURCES = \
camel-pop3-stream.c \
camel-pop3-store.c
-libcamelpop3include_HEADERS = \
+noinst_HEADERS = \
camel-pop3-engine.h \
camel-pop3-folder.h \
camel-pop3-stream.h \
camel-pop3-store.h
-
libcamelpop3_la_LDFLAGS = -avoid-version -module
-libcamelpop3_la_LIBADD = $(top_builddir)/e-util/libeutil.la
+libcamelpop3_la_LIBADD = \
+ $(top_builddir)/libedataserver/libedataserver-${BASE_VERSION}.la
EXTRA_DIST = libcamelpop3.urls