aboutsummaryrefslogtreecommitdiffstats
path: root/calendar/pcs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'calendar/pcs/Makefile.am')
-rw-r--r--calendar/pcs/Makefile.am67
1 files changed, 0 insertions, 67 deletions
diff --git a/calendar/pcs/Makefile.am b/calendar/pcs/Makefile.am
deleted file mode 100644
index 3432837685..0000000000
--- a/calendar/pcs/Makefile.am
+++ /dev/null
@@ -1,67 +0,0 @@
-INCLUDES = \
- -DG_LOG_DOMAIN=\"wombat-pcs\" \
- -I$(top_srcdir) \
- -I$(top_srcdir)/calendar \
- -I$(top_builddir)/calendar \
- -I$(top_srcdir)/libical/src/libical \
- -I$(top_builddir)/libical/src/libical \
- -I$(top_srcdir)/libwombat \
- -I$(top_builddir)/libwombat \
- -DGNOMELOCALEDIR=\""$(localedir)"\" \
- $(EVOLUTION_CALENDAR_CFLAGS)
-
-CORBA_GENERATED_H = \
- evolution-calendar.h
-
-CORBA_GENERATED_C = \
- evolution-calendar-common.c \
- evolution-calendar-skels.c \
- evolution-calendar-stubs.c
-
-CORBA_GENERATED = $(CORBA_GENERATED_H) $(CORBA_GENERATED_C)
-
-idls = \
- $(srcdir)/../idl/evolution-calendar.idl
-
-idl_flags = -I $(srcdir) $(IDL_INCLUDES)
-
-$(CORBA_GENERATED): $(idls)
- $(ORBIT_IDL) $(idl_flags) $(srcdir)/../idl/evolution-calendar.idl
-
-pcsincludedir = $(includedir)/evolution/pcs
-
-privlib_LIBRARIES = libpcs.a
-noinst_LIBRARIES = libpcsfile.a
-
-pcsinclude_HEADERS = \
- $(CORBA_GENERATED_H) \
- cal.h \
- cal-backend.h \
- cal-backend-util.h \
- cal-common.h \
- cal-factory.h \
- job.h \
- query-backend.h \
- query.h
-
-libpcs_a_SOURCES = \
- $(pcsinclude_HEADERS) \
- $(CORBA_GENERATED_C) \
- cal.c \
- cal-backend.c \
- cal-backend-util.c \
- cal-factory.c \
- job.c \
- query-backend.c \
- query.c
-
-libpcsfile_a_SOURCES = \
- cal-backend-file.c \
- cal-backend-file.h
-
-BUILT_SOURCES = $(CORBA_GENERATED)
-CLEANFILES = $(BUILT_SOURCES)
-
-dist-hook:
- cd $(distdir); rm -f $(BUILT_SOURCES)
-