aboutsummaryrefslogtreecommitdiffstats
path: root/art/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'art/Makefile.am')
-rw-r--r--art/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/art/Makefile.am b/art/Makefile.am
index 8428795c1d..88202718ca 100644
--- a/art/Makefile.am
+++ b/art/Makefile.am
@@ -33,12 +33,14 @@ images_DATA = \
plus.png \
minus.png
-install-data-hook:
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
@-if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
$(gtk_update_icon_cache); \
else \
- echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
echo "*** $(gtk_update_icon_cache)"; \
fi