aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/util/Makefile.am')
-rw-r--r--addressbook/util/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/addressbook/util/Makefile.am b/addressbook/util/Makefile.am
new file mode 100644
index 0000000000..51b6e7fc28
--- /dev/null
+++ b/addressbook/util/Makefile.am
@@ -0,0 +1,41 @@
+INCLUDES = \
+ -DPREFIX=\"$(prefix)\" \
+ -DSYSCONFDIR=\"$(sysconfdir)\" \
+ -DDATADIR=\"$(datadir)\" \
+ -DLIBDIR=\"$(libdir)\" \
+ -DG_LOG_DOMAIN=\"EBook\" \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_srcdir)/addressbook/ename \
+ -I$(top_builddir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/ename \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -DG_DISABLE_DEPRECATED \
+ -DLIBGNOME_DISABLE_DEPRECATED \
+ $(EVOLUTION_ADDRESSBOOK_CFLAGS)
+
+noinst_LTLIBRARIES = libeabutil.la
+
+libeabutil_la_SOURCES = \
+ eab-marshal.c \
+ eab-destination.c \
+ eab-destination.h \
+ eab-book-util.c \
+ eab-book-util.h
+
+libeabutil_la_LIBADD = \
+ $(top_builddir)/addressbook/backend/ebook/libebook.la \
+ $(top_builddir)/camel/libcamel.la \
+ $(top_builddir)/e-util/ename/libename.la \
+ $(top_builddir)/e-util/libeutil.la
+
+MARSHAL_GENERATED = eab-marshal.c eab-marshal.h
+@EVO_MARSHAL_RULE@
+
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)
+
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)