aboutsummaryrefslogtreecommitdiffstats
path: root/addressbook/gui/widgets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'addressbook/gui/widgets/Makefile.am')
-rw-r--r--addressbook/gui/widgets/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/addressbook/gui/widgets/Makefile.am b/addressbook/gui/widgets/Makefile.am
index e262e18f5c..eed44c04a2 100644
--- a/addressbook/gui/widgets/Makefile.am
+++ b/addressbook/gui/widgets/Makefile.am
@@ -18,6 +18,7 @@ noinst_LIBRARIES = \
libeminicard.a
libeminicard_a_SOURCES = \
+ e-addressbook-marshal.c \
e-addressbook-reflow-adapter.c \
e-addressbook-reflow-adapter.h \
e-addressbook-table-adapter.c \
@@ -45,6 +46,20 @@ libeminicard_a_SOURCES = \
gal-view-minicard.c \
gal-view-minicard.h
+# GLib marshalling cruft
+
+e-addressbook-marshal.h: e-addressbook-marshal.list
+ ( @GLIB_GENMARSHAL@ --prefix=e_addressbook_marshal e-addressbook-marshal.list --header > e-addressbook-marshal.tmp \
+ && mv e-addressbook-marshal.tmp e-addressbook-marshal.h ) \
+ || ( rm -f e-addressbook-marshal.tmp && exit 1 )
+
+e-addressbook-marshal.c: e-addressbook-marshal.h
+ ( @GLIB_GENMARSHAL@ --prefix=e_addressbook_marshal e-addressbook-marshal.list --body > e-addressbook-marshal.tmp \
+ && mv e-addressbook-marshal.tmp e-addressbook-marshal.c ) \
+ || ( rm -f e-addressbook-marshal.tmp && exit 1 )
+
+MARSHAL_GENERATED = e-addressbook-marshal.c e-addressbook-marshal.h
+
#noinst_PROGRAMS = \
# minicard-widget-test \
# minicard-label-test \
@@ -135,5 +150,5 @@ etspec_DATA= e-addressbook-view.etspec
EXTRA_DIST = \
$(glade_DATA) \
- $(etspec_DATA)
- \ No newline at end of file
+ $(etspec_DATA) \
+ e-addressbook-marshal.list