aboutsummaryrefslogtreecommitdiffstats
path: root/wombat/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2003-10-31 21:28:44 +0800
committerJP Rosevear <jpr@src.gnome.org>2003-10-31 21:28:44 +0800
commitbdf19d320404cc3c0aa6900ea711279f80ceab6a (patch)
tree344bc87daad354aa5ae91ce9e2b9a018d137d7a8 /wombat/Makefile.am
parent318ff6a39433c962150b5bd78e2bd13de7b637d8 (diff)
downloadgsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.gz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.bz2
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.lz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.xz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.zst
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.zip
set up vars and rules for versioning the .server files
2003-10-31 JP Rosevear <jpr@ximian.com> * configure.in: set up vars and rules for versioning the .server files * Makefile.am's: use rules for versioning .server file, ensure built files are removed before disting svn path=/trunk/; revision=23149
Diffstat (limited to 'wombat/Makefile.am')
-rw-r--r--wombat/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/wombat/Makefile.am b/wombat/Makefile.am
index 37e1248ced..0e83a42667 100644
--- a/wombat/Makefile.am
+++ b/wombat/Makefile.am
@@ -64,25 +64,26 @@ GNOME_Evolution_Wombat.server.in.in: $(SERVER_IN_FILE) Makefile
cp $< $@
server_in_files = GNOME_Evolution_Wombat.server.in.in
-
-server_DATA = $(server_in_files:.server.in.in=.server)
-$(server_in_files:.server.in.in=.server.in): $(server_in_files)
- sed -e "s|\@LIBEXECDIR\@|$(privlibexecdir)|" $< > $@
-
+server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)
+@EVO_SUBST_SERVER_RULE@
+@EVO_NAME_SERVER_RULE@
@INTLTOOL_SERVER_RULE@
idl_DATA = $(IDLS)
-EXTRA_DIST = $(server_DATA) \
+EXTRA_DIST = \
$(server_in_files) \
$(idl_DATA) \
ChangeLog.pre-1-4 \
GNOME_Evolution_WombatLDAP.server.in.in \
GNOME_Evolution_WombatNOLDAP.server.in.in
-BUILT_SOURCES = $(IDL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED) $(server_DATA)
CLEANFILES = $(BUILT_SOURCES)
+dist-hook:
+ cd $(distdir); rm -f $(BUILT_SOURCES)
+
if ENABLE_PURIFY
PLINK = $(LIBTOOL) --mode=link $(PURIFY) $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@