aboutsummaryrefslogtreecommitdiffstats
path: root/win32/Makefile.am
diff options
context:
space:
mode:
authorFridrich Strba <fridrich.strba@bluewin.ch>2010-03-06 04:43:30 +0800
committerFridrich Strba <fridrich.strba@bluewin.ch>2010-03-06 04:50:41 +0800
commit855ba06dc0875e0dcffb9c5d388f8b30abd2deb2 (patch)
treeb1d367d8ffe09bbf9f69275339056c1228aafa1c /win32/Makefile.am
parent1d88f36d7fd0a5225c3438adb4782618407f320d (diff)
downloadgsoc2013-evolution-855ba06dc0875e0dcffb9c5d388f8b30abd2deb2.tar
gsoc2013-evolution-855ba06dc0875e0dcffb9c5d388f8b30abd2deb2.tar.gz
gsoc2013-evolution-855ba06dc0875e0dcffb9c5d388f8b30abd2deb2.tar.bz2
gsoc2013-evolution-855ba06dc0875e0dcffb9c5d388f8b30abd2deb2.tar.lz
gsoc2013-evolution-855ba06dc0875e0dcffb9c5d388f8b30abd2deb2.tar.xz
gsoc2013-evolution-855ba06dc0875e0dcffb9c5d388f8b30abd2deb2.tar.zst
gsoc2013-evolution-855ba06dc0875e0dcffb9c5d388f8b30abd2deb2.zip
Remove a long lived win32 hack
It seems that the dummy libraries are not needed anymore on windows nowadays.
Diffstat (limited to 'win32/Makefile.am')
-rw-r--r--win32/Makefile.am66
1 files changed, 0 insertions, 66 deletions
diff --git a/win32/Makefile.am b/win32/Makefile.am
deleted file mode 100644
index 7720d56543..0000000000
--- a/win32/Makefile.am
+++ /dev/null
@@ -1,66 +0,0 @@
-EXTRA_DIST = \
- dummy.la \
- libemiscwidgets.def \
- libetable.def \
- libetext.def \
- libevolution-addressbook.def \
- libevolution-calendar.def \
- libevolution-mail.def \
- libfilter.def
-
-if OS_WIN32
-BOOTSTRAP_LIBS = \
- libemiscwidgets.la \
- libetable.la \
- libetext.la \
- libevolution-addressbook.la \
- libevolution-calendar.la \
- libevolution-mail.la \
- libfilter.la
-endif
-
-noinst_DATA = $(BOOTSTRAP_LIBS)
-
-# Yes, it's a bit silly to repeat the same command sequence here
-# multiple times, but on the other hand there are subtle differences:
-# Part of the DLLs have -0 in the name, part don't. (Those linked with
-# libtool's -module -avoid-version options don't get the -0 suffix.)
-
-libemiscwidgets.la: dummy.la libemiscwidgets.def
- sed -e s!%DLL%!libemiscwidgets-0! -e s!%LIB%!libemiscwidgets! -e s!%PFX%!$(prefix)! <dummy.la >$@
- mkdir -p .libs
- $(DLLTOOL) --output-lib=.libs/libemiscwidgets.dll.a --dllname=libemiscwidgets-0.dll --input-def=libemiscwidgets.def
-
-libetable.la: dummy.la libetable.def
- sed -e s!%DLL%!libetable-0! -e s!%LIB%!libetable! -e s!%PFX%!$(prefix)! <dummy.la >$@
- mkdir -p .libs
- $(DLLTOOL) --output-lib=.libs/libetable.dll.a --dllname=libetable-0.dll --input-def=libetable.def
-
-libetext.la: dummy.la libetext.def
- sed -e s!%DLL%!libetext-0! -e s!%LIB%!libetext! -e s!%PFX%!$(prefix)! <dummy.la >$@
- mkdir -p .libs
- $(DLLTOOL) --output-lib=.libs/libetext.dll.a --dllname=libetext-0.dll --input-def=libetext.def
-
-libevolution-addressbook.la: dummy.la libevolution-addressbook.def
- sed -e s!%DLL%!libevolution-addressbook! -e s!%LIB%!libevolution-addressbook! -e s!%PFX%!$(prefix)! <dummy.la >$@
- mkdir -p .libs
- $(DLLTOOL) --output-lib=.libs/libevolution-addressbook.dll.a --dllname=libevolution-addressbook.dll --input-def=libevolution-addressbook.def
-
-libevolution-calendar.la: dummy.la libevolution-calendar.def
- sed -e s!%DLL%!libevolution-calendar! -e s!%LIB%!libevolution-calendar! -e s!%PFX%!$(prefix)! <dummy.la >$@
- mkdir -p .libs
- $(DLLTOOL) --output-lib=.libs/libevolution-calendar.dll.a --dllname=libevolution-calendar.dll --input-def=libevolution-calendar.def
-
-libevolution-mail.la: dummy.la libevolution-mail.def
- sed -e s!%DLL%!libevolution-mail! -e s!%LIB%!libevolution-mail! -e s!%PFX%!$(prefix)! <dummy.la >$@
- mkdir -p .libs
- $(DLLTOOL) --output-lib=.libs/libevolution-mail.dll.a --dllname=libevolution-mail.dll --input-def=libevolution-mail.def
-
-libfilter.la: dummy.la libfilter.def
- sed -e s!%DLL%!libfilter-0! -e s!%LIB%!libfilter! -e s!%PFX%!$(prefix)! <dummy.la >$@
- mkdir -p .libs
- $(DLLTOOL) --output-lib=.libs/libfilter.dll.a --dllname=libfilter-0.dll --input-def=libfilter.def
-
-CLEANFILES = $(BOOTSTRAP_LIBS)
-
--include $(top_srcdir)/git.mk