aboutsummaryrefslogtreecommitdiffstats
path: root/widgets/misc/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-06-25 00:59:33 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-06-25 06:29:22 +0800
commitf0d3f3afdfa314e1e8cd7d8da790878008a46aad (patch)
tree7116e2a18c7bd50633b2f8de42b5377af1e8172a /widgets/misc/Makefile.am
parent94302ea73cde0b470faad653f752406f19f202d7 (diff)
downloadgsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.gz
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.bz2
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.lz
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.xz
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.zst
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.zip
Radically reorganize source code.
- Collect all shell modules into a new top-level 'modules' directory: $(top_srcdir)/modules/addressbook $(top_srcdir)/modules/calendar $(top_srcdir)/modules/mail Nothing is allowed to link to these, not plugins nor other modules. THIS SOLVES BUG #571275 AND OPENS THE DOOR TO PORTING TO MAC OS X. - Mimic the libevolution-mail-shared library from master (except drop the "shared" suffix) and have libevolution-mail-importers and all mail-related plugins link to it. - Discard the a11y subdirectories and have the files live alongside their counterpart widgets.
Diffstat (limited to 'widgets/misc/Makefile.am')
-rw-r--r--widgets/misc/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/widgets/misc/Makefile.am b/widgets/misc/Makefile.am
index cbbd283fb2..c7123d6977 100644
--- a/widgets/misc/Makefile.am
+++ b/widgets/misc/Makefile.am
@@ -84,9 +84,9 @@ widgetsinclude_HEADERS = \
e-spinner.h \
e-timeout-activity.h \
e-url-entry.h \
- a11y/ea-calendar-cell.h \
- a11y/ea-calendar-item.h \
- a11y/ea-widgets.h
+ ea-calendar-cell.h \
+ ea-calendar-item.h \
+ ea-widgets.h
libemiscwidgets_la_SOURCES = \
$(widgetsinclude_HEADERS) \
@@ -145,9 +145,9 @@ libemiscwidgets_la_SOURCES = \
e-signature-tree-view.c \
e-timeout-activity.c \
e-url-entry.c \
- a11y/ea-calendar-cell.c \
- a11y/ea-calendar-item.c \
- a11y/ea-widgets.c
+ ea-calendar-cell.c \
+ ea-calendar-item.c \
+ ea-widgets.c
libemiscwidgets_la_LDFLAGS = $(NO_UNDEFINED)