aboutsummaryrefslogtreecommitdiffstats
path: root/smime/lib/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2003-11-13 10:23:52 +0800
committerChris Toshok <toshok@src.gnome.org>2003-11-13 10:23:52 +0800
commitbdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea (patch)
tree18089837a8fe8eb029233dac94a8f5a06d9ea39b /smime/lib/Makefile.am
parent7e734202c2be76070d5f9a0af821f03191aaf25e (diff)
downloadgsoc2013-evolution-bdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea.tar
gsoc2013-evolution-bdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea.tar.gz
gsoc2013-evolution-bdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea.tar.bz2
gsoc2013-evolution-bdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea.tar.lz
gsoc2013-evolution-bdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea.tar.xz
gsoc2013-evolution-bdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea.tar.zst
gsoc2013-evolution-bdba680ed59ee12b4bdcdae2d5a6c3e8cc59daea.zip
implement using the e-cert-trust foo. (e_cert_get_email): implement.
2003-11-12 Chris Toshok <toshok@ximian.com> * lib/e-cert.c (e_cert_get_cert_type): implement using the e-cert-trust foo. (e_cert_get_email): implement. * lib/e-cert.h: add UNKNOWN cert type. * gui/smime-ui.glade: fix capitalization of "Import" on the contact certificate page. * gui/certificate-manager.c (import_contact): new function. implement email cert importing. (delete_contact): new function. (unload_certs): implement for E_CERT_CONTACT. (certificate_manager_config_control_new): get the contact cert action buttons from libglade. * lib/e-cert-db.c (handle_ca_cert_download): mostly implement the trust settings correctly. this still needs work pending the CA trust dialog's completion. (e_cert_db_delete_cert): fix the ifdef'ed code. (e_cert_db_import_user_cert): remove the ifdef'ed body of this, since it was copied from the CA code. * lib/Makefile.am (libessmime_la_SOURCES): add e-cert-trust.[ch] * lib/e-cert-trust.[ch]: new files, basically c&p nsNSSCertTrust from mozilla's PSM. svn path=/trunk/; revision=23308
Diffstat (limited to 'smime/lib/Makefile.am')
-rw-r--r--smime/lib/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/smime/lib/Makefile.am b/smime/lib/Makefile.am
index 260238ba35..07093ef5c9 100644
--- a/smime/lib/Makefile.am
+++ b/smime/lib/Makefile.am
@@ -22,5 +22,7 @@ noinst_LTLIBRARIES = libessmime.la
libessmime_la_SOURCES = \
e-cert.c \
e-cert.h \
+ e-cert-trust.c \
+ e-cert-trust.h \
e-cert-db.c \
e-cert-db.h