aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@ximian.com>2002-05-15 05:07:48 +0800
committerChris Lahey <clahey@src.gnome.org>2002-05-15 05:07:48 +0800
commitf8cc61843c45d07d11872e767c1cee0f16d48409 (patch)
treeb9419ea08a2c748c9c137a83ca6cf32e81fed7e0 /shell/Makefile.am
parentb1d181a33be9acc6f33acf5e59abd044527d25c8 (diff)
downloadgsoc2013-evolution-f8cc61843c45d07d11872e767c1cee0f16d48409.tar
gsoc2013-evolution-f8cc61843c45d07d11872e767c1cee0f16d48409.tar.gz
gsoc2013-evolution-f8cc61843c45d07d11872e767c1cee0f16d48409.tar.bz2
gsoc2013-evolution-f8cc61843c45d07d11872e767c1cee0f16d48409.tar.lz
gsoc2013-evolution-f8cc61843c45d07d11872e767c1cee0f16d48409.tar.xz
gsoc2013-evolution-f8cc61843c45d07d11872e767c1cee0f16d48409.tar.zst
gsoc2013-evolution-f8cc61843c45d07d11872e767c1cee0f16d48409.zip
Added check-empty.xpm, check-filled.xpm, and check-missing.xpm.
2002-05-14 Christopher James Lahey <clahey@ximian.com> * Makefile.am: Added check-empty.xpm, check-filled.xpm, and check-missing.xpm. * check-empty.xpm, check-filled.xpm, check-missing.xpm: New xpms. Copied from gal. check-missing.xpm is simply a transparent xpm of the correct size. * e-storage-set-view.c (etree_value_at): When getting, check if the path doesn't have a check box and return 2 in that case. (etree_set_value_at): Check if the path doesn't have a check box and don't change it in that case. Also, just invert the value here instead of paying attention to the set value passed in. (class_init): Initialize the checks GdkPixbufs. (e_storage_set_view_construct): Create the "optional_checkbox" cell. * e-storage-set-view.etspec: Changed the cell for the checkbox column to "optional_checkbox". svn path=/trunk/; revision=16791
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 90f6707c3c..8bbdb5eff8 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -252,11 +252,17 @@ etspec_DATA = \
@XML_I18N_MERGE_OAF_RULE@
+icons = \
+ check-empty.xpm \
+ check-filled.xpm \
+ check-missing.xpm
+
EXTRA_DIST = \
$(IDLS) \
$(oaf_in_files) \
$(oaf_DATA) \
$(etspec_DATA) \
+ $(icons) \
GNOME_Evolution_TestComponent.oaf
# Purify support