aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2009-05-20 22:50:00 +0800
committerMilan Crha <mcrha@redhat.com>2009-05-20 22:50:00 +0800
commitf4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81 (patch)
tree1c0228db536f5fa0efc6e0f779bb86df610989d0 /shell/Makefile.am
parent3acc45b10c9849aa5385a762b4d139472916dca1 (diff)
downloadgsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.gz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.bz2
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.lz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.xz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.zst
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.zip
Use -no-undefined on Linux too
There still left two things opened, search for KILL-BONOBO to find them. One is in calendar's Makefile.am, one in composer.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am23
1 files changed, 12 insertions, 11 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 92262d6477..e8c8dc4d95 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -59,6 +59,7 @@ privsolib_LTLIBRARIES = \
eshellincludedir = $(privincludedir)/shell
eshellinclude_HEADERS = \
+ e-shell.h \
e-shell-backend.h \
e-shell-common.h \
e-shell-content.h \
@@ -68,11 +69,11 @@ eshellinclude_HEADERS = \
e-shell-taskbar.h \
e-shell-view.h \
e-shell-window.h \
- e-shell-window-actions.h \
es-event.h
libeshell_la_SOURCES = \
$(IDL_GENERATED) \
+ e-shell.c \
e-shell-backend.c \
e-shell-content.c \
e-shell-settings.c \
@@ -81,13 +82,22 @@ libeshell_la_SOURCES = \
e-shell-taskbar.c \
e-shell-view.c \
e-shell-window.c \
+ e-shell-window-private.c \
+ e-shell-window-private.h \
+ $(eshellinclude_HEADERS) \
+ e-shell-importer.c \
+ e-shell-importer.h \
+ e-shell-migrate.c \
+ e-shell-migrate.h \
+ e-shell-window-actions.h \
e-shell-window-actions.c \
- $(eshellinclude_HEADERS)
+ es-event.c
libeshell_la_LDFLAGS = $(NO_UNDEFINED)
libeshell_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/filter/libfilter.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
$(top_builddir)/widgets/menus/libmenus.la \
$(SHELL_LIBS)
@@ -103,15 +113,6 @@ evolution_SOURCES = \
$(NM_SUPPORT_FILES) \
e-config-upgrade.c \
e-config-upgrade.h \
- e-shell.c \
- e-shell.h \
- e-shell-importer.c \
- e-shell-importer.h \
- e-shell-migrate.c \
- e-shell-migrate.h \
- e-shell-window-private.c \
- e-shell-window-private.h \
- es-event.c \
main.c
evolution_LDADD = \