aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@gnome.org>2010-07-16 01:09:23 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-07-26 09:30:00 +0800
commitd46c4b4e5bcaefd116b0ee0e49af951c31019990 (patch)
tree25d9fa8eb322437c3b115d1b5414944e7551da45 /shell/Makefile.am
parentb9564c4d01c08c976e01256b308e3f2891c6e164 (diff)
downloadgsoc2013-evolution-d46c4b4e5bcaefd116b0ee0e49af951c31019990.tar
gsoc2013-evolution-d46c4b4e5bcaefd116b0ee0e49af951c31019990.tar.gz
gsoc2013-evolution-d46c4b4e5bcaefd116b0ee0e49af951c31019990.tar.bz2
gsoc2013-evolution-d46c4b4e5bcaefd116b0ee0e49af951c31019990.tar.lz
gsoc2013-evolution-d46c4b4e5bcaefd116b0ee0e49af951c31019990.tar.xz
gsoc2013-evolution-d46c4b4e5bcaefd116b0ee0e49af951c31019990.tar.zst
gsoc2013-evolution-d46c4b4e5bcaefd116b0ee0e49af951c31019990.zip
Add optional clutter support.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 3cae585252..7fd03afaa3 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -59,6 +59,7 @@ libeshell_la_CPPFLAGS = \
-DG_LOG_DOMAIN=\"evolution-shell\" \
$(EVOLUTION_DATA_SERVER_CFLAGS) \
$(GNOME_PLATFORM_CFLAGS) \
+ $(CLUTTER_CFLAGS) \
$(TZDIALOG_CFLAGS) \
$(SHELL_CFLAGS)
@@ -95,6 +96,7 @@ libeshell_la_LIBADD = \
$(top_builddir)/widgets/menus/libmenus.la \
$(EVOLUTION_DATA_SERVER_LIBS) \
$(GNOME_PLATFORM_LIBS) \
+ $(CLUTTER_LIBS) \
$(SHELL_LIBS)
# Evolution executable
@@ -122,11 +124,13 @@ evolution_CPPFLAGS = \
-DEVOLUTION_TOOLSDIR=\""$(privlibexecdir)"\" \
-DEVOLUTION_UIDIR=\""$(uidir)"\" \
-DPREFIX=\""$(prefix)"\" \
+ -DEVOLUTION_MX_THEMEDIR=\"$(privdatadir)/theme\" \
-DSYSCONFDIR=\""$(sysconfdir)"\" \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(datadir)"\" \
$(GNOME_PLATFORM_CFLAGS) \
$(TZDIALOG_CFLAGS) \
+ $(CLUTTER_CFLAGS) \
$(SHELL_CFLAGS)
evolution_SOURCES = \
@@ -142,6 +146,7 @@ evolution_LDADD = \
$(TZDIALOG_LIBS) \
$(SHELL_LIBS) \
$(GNOME_PLATFORM_LIBS) \
+ $(CLUTTER_LIBS) \
$(EVOLUTIONICON)
if OS_WIN32