aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-05-04 21:08:32 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-05-04 21:08:32 +0800
commitc3e0648d8b5a1d73f82f0a7691b9ab1320248392 (patch)
tree677c9472380b3119d08f42eb48c001d18bfd6243 /shell/Makefile.am
parent5395bd3308e25f3ca2ac1b35460ba6df1d294f4b (diff)
parentfb970ccf14e33d92cfb9409d44f7b06355e958fc (diff)
downloadgsoc2013-evolution-c3e0648d8b5a1d73f82f0a7691b9ab1320248392.tar
gsoc2013-evolution-c3e0648d8b5a1d73f82f0a7691b9ab1320248392.tar.gz
gsoc2013-evolution-c3e0648d8b5a1d73f82f0a7691b9ab1320248392.tar.bz2
gsoc2013-evolution-c3e0648d8b5a1d73f82f0a7691b9ab1320248392.tar.lz
gsoc2013-evolution-c3e0648d8b5a1d73f82f0a7691b9ab1320248392.tar.xz
gsoc2013-evolution-c3e0648d8b5a1d73f82f0a7691b9ab1320248392.tar.zst
gsoc2013-evolution-c3e0648d8b5a1d73f82f0a7691b9ab1320248392.zip
Merge branch 'master' into kill-bonobo
Conflicts: addressbook/gui/Makefile.am addressbook/gui/widgets/Makefile.am addressbook/gui/widgets/eab-popup-control.c calendar/gui/e-meeting-time-sel.c calendar/gui/migration.c calendar/modules/e-memo-shell-module-migrate.h e-util/e-logger.c mail/e-mail-attachment-bar.c mail/em-composer-utils.c mail/em-format-html-display.c plugins/mail-account-disable/Makefile.am plugins/select-one-source/Makefile.am po/es.po shell/Makefile.am shell/e-shell-common.h shell/e-shell-nm.c shell/e-shell-window-commands.c shell/e-shell-window.c shell/e-sidebar.c shell/e-user-creatable-items-handler.c shell/importer/Makefile.am shell/test/Makefile.am widgets/misc/test-error.c widgets/misc/test-info-label.c widgets/misc/test-multi-config-dialog.c
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d20b49a3d0..8fd5896fe3 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -94,6 +94,10 @@ libeshell_la_LIBADD = \
# Evolution executable
+if HAVE_WINDRES
+EVOLUTIONICONRC = evolution-icon.o
+endif
+
evolution_SOURCES = \
$(DATASERVER_IDL_GENERATED) \
$(NM_SUPPORT_FILES) \
@@ -117,7 +121,8 @@ evolution_LDADD = \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
$(top_builddir)/e-util/libeutil.la \
$(TZDIALOG_LIBS) \
- $(SHELL_LIBS)
+ $(SHELL_LIBS) \
+ $(EVOLUTIONICONRC)
if OS_WIN32
evolution_LDFLAGS = -mwindows
@@ -191,7 +196,12 @@ EXTRA_DIST = \
$(glade_DATA) \
$(schema_in_files) \
ChangeLog.pre-1-4 \
- evolution-nognome.in
+ evolution-nognome.in \
+ evolution-icon.rc \
+ evolution.ico \
+ evolution-mail.ico \
+ evolution-memos.ico \
+ evolution-tasks.ico
# Purify support
@@ -217,5 +227,7 @@ dist-hook:
noinst_SCRIPTS = evolution-nognome
+evolution-icon.o: evolution.ico evolution-mail.ico evolution-memos.ico evolution-tasks.ico
+ $(WINDRES) evolution-icon.rc evolution-icon.o
-include $(top_srcdir)/git.mk