aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-08-10 18:06:41 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-08-10 18:06:41 +0800
commitc03e685846f21347e5a0e9943870e99162b0bae8 (patch)
treee91c0f0af1a19949c41413d4ab892a0947cb4808 /shell/Makefile.am
parentac6b7634779ef3aa145b3e5da6b726ccaf288b00 (diff)
downloadgsoc2013-evolution-c03e685846f21347e5a0e9943870e99162b0bae8.tar
gsoc2013-evolution-c03e685846f21347e5a0e9943870e99162b0bae8.tar.gz
gsoc2013-evolution-c03e685846f21347e5a0e9943870e99162b0bae8.tar.bz2
gsoc2013-evolution-c03e685846f21347e5a0e9943870e99162b0bae8.tar.lz
gsoc2013-evolution-c03e685846f21347e5a0e9943870e99162b0bae8.tar.xz
gsoc2013-evolution-c03e685846f21347e5a0e9943870e99162b0bae8.tar.zst
gsoc2013-evolution-c03e685846f21347e5a0e9943870e99162b0bae8.zip
Use privsolib instead of privlib. Link with SHELL_LIBS. Use NO_UNDEFINED.
2005-08-10 Tor Lillqvist <tml@novell.com> * Makefile.am: Use privsolib instead of privlib. Link with SHELL_LIBS. Use NO_UNDEFINED. Use EXEEXT. Use hack to workaround MSYS feature on Win32 when installing the schemas. (INCLUDES): Define EVOLUTION_IMAGESDIR like in ../e-util/e-util-private.h, not EVOLUTION_IMAGES. (idl_defines): Pass marker macro to IDL compiler, see below. * Evolution-Component.idl: Don't generate duplicate code in skels and stubs when including this file from other idl files (in particular, ../mail/Evolution-Mail.idl). Use the include_defs and inhibit pragmas unless IDL-compiling in this directory. See lists.ximian.com/pipermail/evolution-patches/2005-June/010899.html * e-shell-utils.c * e-shell-windows.c: Ue EVOLUTION_IMAGESDIR in such a way that it works even when it is a function call. svn path=/trunk/; revision=30075
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am49
1 files changed, 34 insertions, 15 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 5e73e5403e..2ad1275a6f 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -4,7 +4,7 @@ INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/shell \
-I$(top_builddir)/shell \
- -DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
+ -DEVOLUTION_IMAGESDIR=\""$(imagesdir)"\" \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
@@ -39,10 +39,13 @@ IDL_GENERATED_C = \
Evolution-skels.c \
Evolution-stubs.c
+idl_defines = \
+ -D__evolution_shell_COMPILATION
+
IDL_GENERATED = $(IDL_GENERATED_H) $(IDL_GENERATED_C)
$(IDL_GENERATED_H): $(IDLS)
- $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(srcdir)/Evolution.idl
+ $(ORBIT_IDL) -I $(srcdir) $(idl_defines) $(IDL_INCLUDES) $(srcdir)/Evolution.idl
$(IDL_GENERATED_C): $(IDL_GENERATED_H)
@@ -70,7 +73,7 @@ idl_DATA = $(IDLS)
# Shell library
-privlib_LTLIBRARIES = \
+privsolib_LTLIBRARIES = \
libeshell.la
eshellincludedir = $(privincludedir)/shell
@@ -93,9 +96,12 @@ libeshell_la_SOURCES = \
evolution-shell-component-utils.c \
$(eshellinclude_HEADERS)
-libeshell_la_LIBADD = \
- $(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/widgets/misc/libemiscwidgets.la
+libeshell_la_LDFLAGS = $(NO_UNDEFINED)
+
+libeshell_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(SHELL_LIBS)
# Evolution executable
@@ -155,7 +161,7 @@ libevolution_test_la_LIBADD = \
libeshell.la \
$(EVOLUTION_TEST_LIBS)
-libevolution_test_la_LDFLAGS = -avoid-version -module
+libevolution_test_la_LDFLAGS = -avoid-version -module $(NO_UNDEFINED)
if ENABLE_TEST_COMPONENT
testserver_in_files = GNOME_Evolution_Test.server.in.in
@@ -188,24 +194,37 @@ schema_DATA = $(schema_in_files:.schemas.in.in=-$(BASE_VERSION).schemas)
@INTLTOOL_SCHEMAS_RULE@
+if OS_WIN32
install-data-local:
- if test -z "$(DESTDIR)" ; then \
- for p in $(schema_DATA) ; do \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p; \
- done \
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ (echo set GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE); \
+ echo $(GCONFTOOL) --makefile-install-rule $$p) >_temp.bat; \
+ cmd /c _temp.bat; \
+ rm _temp.bat; \
+ done \
fi
+else
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) \
+ $(GCONFTOOL) --makefile-install-rule $$p; \
+ done \
+ fi
+endif
install-evolution:
$(mkinstalldirs) $(DESTDIR)$(bindir)
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution$(EXEEXT) $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)$(EXEEXT)
if DEFAULT_BINARY
- cd $(DESTDIR)$(bindir) && rm -f evolution && $(LN_S) evolution-$(BASE_VERSION) evolution
+ cd $(DESTDIR)$(bindir) && rm -f evolution$(EXEEXT) && $(LN_S) evolution-$(BASE_VERSION)$(EXEEXT) evolution$(EXEEXT)
endif
uninstall-evolution:
- $(LIBTOOL) --mode=uninstall rm -rf $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+ $(LIBTOOL) --mode=uninstall rm -rf $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)$(EXEEXT)
if DEFAULT_BINARY
- rm -f $(DESTDIR)$(bindir)/evolution
+ rm -f $(DESTDIR)$(bindir)/evolution$(EXEEXT)
endif
if HAVE_DTAPPINTEGRATE