aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2003-10-31 21:28:44 +0800
committerJP Rosevear <jpr@src.gnome.org>2003-10-31 21:28:44 +0800
commitbdf19d320404cc3c0aa6900ea711279f80ceab6a (patch)
tree344bc87daad354aa5ae91ce9e2b9a018d137d7a8 /shell/Makefile.am
parent318ff6a39433c962150b5bd78e2bd13de7b637d8 (diff)
downloadgsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.gz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.bz2
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.lz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.xz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.zst
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.zip
set up vars and rules for versioning the .server files
2003-10-31 JP Rosevear <jpr@ximian.com> * configure.in: set up vars and rules for versioning the .server files * Makefile.am's: use rules for versioning .server file, ensure built files are removed before disting svn path=/trunk/; revision=23149
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 57fdbfcc99..ac0e2d75d9 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -252,16 +252,13 @@ install-test-component: evolution-test-component
# Misc stuff
server_in_files = GNOME_Evolution_Shell.server.in.in
-server_DATA = $(server_in_files:.server.in.in=.server)
-%.server.in: %.server.in.in
- sed -e "s|\@BINDIR\@|$(bindir)|" \
- -e "s|\@VERSION\@|$(BASE_VERSION)|" \
- $< > $@
+server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)
+@EVO_SUBST_SERVER_RULE@
+@EVO_NAME_SERVER_RULE@
+@INTLTOOL_SERVER_RULE@
etspec_DATA = e-storage-set-view.etspec
-@INTLTOOL_SERVER_RULE@
-
icons = \
check-empty.xpm \
check-filled.xpm \
@@ -308,7 +305,6 @@ MARSHAL_GENERATED = e-shell-marshal.c e-shell-marshal.h
EXTRA_DIST = \
$(IDLS) \
$(server_in_files) \
- $(server_DATA) \
$(etspec_DATA) \
$(schema_DATA) \
$(icons) \