aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2000-07-20 21:37:56 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2000-07-20 21:37:56 +0800
commitb40242c395b0eec33a622ddfe90634fd6d63e4c6 (patch)
treeaecb84b01ffb6c3536c5db0c26165df4f51d860a /shell/Makefile.am
parent8aec5bf2be2fbfdfb4cecd6c48a77d197db41d39 (diff)
downloadgsoc2013-evolution-b40242c395b0eec33a622ddfe90634fd6d63e4c6.tar
gsoc2013-evolution-b40242c395b0eec33a622ddfe90634fd6d63e4c6.tar.gz
gsoc2013-evolution-b40242c395b0eec33a622ddfe90634fd6d63e4c6.tar.bz2
gsoc2013-evolution-b40242c395b0eec33a622ddfe90634fd6d63e4c6.tar.lz
gsoc2013-evolution-b40242c395b0eec33a622ddfe90634fd6d63e4c6.tar.xz
gsoc2013-evolution-b40242c395b0eec33a622ddfe90634fd6d63e4c6.tar.zst
gsoc2013-evolution-b40242c395b0eec33a622ddfe90634fd6d63e4c6.zip
Add support for saving the current configuration of all the
components. svn path=/trunk/; revision=4237
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index dbcc08cac6..782e849d3a 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -21,6 +21,7 @@ CLEANFILES = $(IDL_GENERATED)
IDLS = \
Evolution.idl \
+ Evolution-Session.idl \
Evolution-Shell.idl \
Evolution-ShellComponent.idl \
Evolution-Storage.idl
@@ -37,6 +38,12 @@ $(IDL_GENERATED): $(IDLS)
$(ORBIT_IDL) -I$(datadir)/idl -I`$(GNOME_CONFIG) --datadir`/idl \
-I$(srcdir) $(srcdir)/Evolution.idl
+# bonobo-idl stuff.
+# (Automatically generated GTK+ object wrappers for CORBA interface implementations).
+
+evolution-session.c: evolution-session.bcd
+ bonobo-idl evolution-session.bcd
+
# Shell library
noinst_LIBRARIES = \
@@ -44,10 +51,14 @@ noinst_LIBRARIES = \
libeshell_a_SOURCES = \
$(IDL_GENERATED) \
+ evolution-session.c \
+ evolution-session.h \
evolution-shell-client.c \
evolution-shell-client.h \
evolution-shell-component.c \
evolution-shell-component.h \
+ evolution-shell-component-client.c \
+ evolution-shell-component-client.h \
evolution-storage.c \
evolution-storage.h
@@ -97,10 +108,6 @@ evolution_SOURCES = \
e-storage-set.h \
e-storage.c \
e-storage.h \
- evolution-shell-client.c \
- evolution-shell-client.h \
- evolution-shell-component-client.c \
- evolution-shell-component-client.h \
main.c
evolution_LDADD = \