aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:25:15 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:25:15 +0800
commit9d14474e02c1064bc58f29376565a2446c99f99c (patch)
treedeb8a7e397feee1e102770841e1800f90c6e6d3c /shell/Makefile.am
parent62e341e4c53d9d28e9ec5ffadfa56a1f1947ae15 (diff)
downloadgsoc2013-evolution-9d14474e02c1064bc58f29376565a2446c99f99c.tar
gsoc2013-evolution-9d14474e02c1064bc58f29376565a2446c99f99c.tar.gz
gsoc2013-evolution-9d14474e02c1064bc58f29376565a2446c99f99c.tar.bz2
gsoc2013-evolution-9d14474e02c1064bc58f29376565a2446c99f99c.tar.lz
gsoc2013-evolution-9d14474e02c1064bc58f29376565a2446c99f99c.tar.xz
gsoc2013-evolution-9d14474e02c1064bc58f29376565a2446c99f99c.tar.zst
gsoc2013-evolution-9d14474e02c1064bc58f29376565a2446c99f99c.zip
Install the shell executable as evolution-$(BASE_VERSION) using an
* Makefile.am: Install the shell executable as evolution-$(BASE_VERSION) using an install-exec-local hack. Also put libeshell in $(privlibdir) instead of $(libdir). (eshellincludedir): Version using $(BASE_VERSION). (INCLUDES): Update for the new locations of things. (etspecdir): Likewise. * e-shell-view.c (e_shell_view_construct): Get evolution.xml from EVOLUTION_UIDIR. * importer/Makefile.am: Install libevolution-importer in $(privlibdir) instead of $(libdir). (INCLUDES): Updated for the new versioned paths. Define EVOLUTION_UIDIR. (libevolution_importerincludedir): Version using $(BASE_VERSION). (gladedir): Likewise. * glade/Makefile.am (gladedir): Version using $(BASE_VERSION). * e-setup.c (DEFAULT_USER_PATH): New #define. (check_evolution_directory): Use it. (copy_default_stuff): Likewise. Also, remove old shortcuts.xml removal cruft. svn path=/trunk/; revision=19565
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am63
1 files changed, 31 insertions, 32 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 19b83e9b26..14538d0557 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -1,24 +1,27 @@
SUBDIRS = glade importer
-INCLUDES = \
- -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED \
- -I$(top_srcdir)/widgets \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_srcdir)/libical/src/libical \
- -I$(top_builddir)/libical/src/libical \
- -I$(top_srcdir) \
- -DEVOLUTION_IMAGES=\""$(datadir)/evolution/images"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DPREFIX=\"$(prefix)\" \
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
- -DDATADIR=\""$(datadir)"\" \
- -DLIBDIR=\""$(datadir)"\" \
- -DG_LOG_DOMAIN=\"evolution-shell\" \
+INCLUDES = \
+ -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir)/libical/src/libical \
+ -I$(top_builddir)/libical/src/libical \
+ -I$(top_srcdir) \
+ -DEVOLUTION_IMAGES=\""$(datadir)/evolution-$(BASE_VERSION)/images"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\"$(datadir)/evolution-$(BASE_VERSION)/glade\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ -DPREFIX=\"$(prefix)\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(datadir)"\" \
+ -DG_LOG_DOMAIN=\"evolution-shell\" \
$(SHELL_CFLAGS)
+noinst_PROGRAMS = evolution evolution-test-component
+
# Shell CORBA stuff
IDLS = \
@@ -68,10 +71,10 @@ idl_DATA = $(IDLS)
# Shell library
-lib_LTLIBRARIES = \
+privlib_LTLIBRARIES = \
libeshell.la
-eshellincludedir = $(includedir)/evolution/shell
+eshellincludedir = $(includedir)/evolution-$(BASE_VERSION)/shell
eshellinclude_HEADERS = \
Evolution.h \
@@ -119,8 +122,6 @@ libeshell_la_SOURCES = \
# Evolution executable
-bin_PROGRAMS = evolution
-
evolution_SOURCES = \
$(SELECT_NAMES_IDL_GENERATED) \
e-activity-handler.c \
@@ -235,9 +236,6 @@ evolution_LDFLAGS = -export-dynamic
# Test component
-noinst_PROGRAMS = \
- evolution-test-component
-
evolution_test_component_SOURCES = \
evolution-test-component.c
@@ -246,7 +244,6 @@ evolution_test_component_LDADD = \
$(SHELL_LIBS)
install-test-component: evolution-test-component
- $(mkinstalldirs) $(DESTDIR)$(bindir)
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution-test-component $(DESTDIR)$(bindir)/evolution-test-component
$(mkinstalldirs) $(DESTDIR)$(serverdir)
$(INSTALL_DATA) $(srcdir)/GNOME_Evolution_TestComponent.server $(DESTDIR)$(serverdir)/GNOME_Evolution_TestComponent.server
@@ -259,9 +256,8 @@ server_DATA = $(server_in_files:.server.in.in=.server)
$(server_in_files:.server.in.in=.server.in): $(server_in_files)
sed -e "s|\@BINDIR\@|$(bindir)|" $< > $@
-etspecdir = $(datadir)/evolution/etspec/
-etspec_DATA = \
- e-storage-set-view.etspec
+etspecdir = $(datadir)/evolution-$(BASE_VERSION)/etspec/
+etspec_DATA = e-storage-set-view.etspec
@INTLTOOL_SERVER_RULE@
@@ -276,12 +272,15 @@ schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_DATA = apps_evolution_shell.schemas
install-data-local:
- if test -z "$(DESTDIR)" ; then \
- for p in $(schema_DATA) ; do \
- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
- done \
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p; \
+ done \
fi
+install-exec-local:
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)
+
# GLib marshalling cruft