aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorChris Toshok <toshok@ximian.com>2002-05-24 20:36:56 +0800
committerChris Toshok <toshok@src.gnome.org>2002-05-24 20:36:56 +0800
commit9529bae97d33cf727914fdbff77decc8da97cc33 (patch)
tree2575d4907e7c03cd31569b03be67381966784867 /shell/Makefile.am
parent5009d8d479665301efdec3beb784e252fa29527d (diff)
downloadgsoc2013-evolution-9529bae97d33cf727914fdbff77decc8da97cc33.tar
gsoc2013-evolution-9529bae97d33cf727914fdbff77decc8da97cc33.tar.gz
gsoc2013-evolution-9529bae97d33cf727914fdbff77decc8da97cc33.tar.bz2
gsoc2013-evolution-9529bae97d33cf727914fdbff77decc8da97cc33.tar.lz
gsoc2013-evolution-9529bae97d33cf727914fdbff77decc8da97cc33.tar.xz
gsoc2013-evolution-9529bae97d33cf727914fdbff77decc8da97cc33.tar.zst
gsoc2013-evolution-9529bae97d33cf727914fdbff77decc8da97cc33.zip
[ fixes 90% of #25047 ] shamelessly lifted from
2002-05-24 Chris Toshok <toshok@ximian.com> [ fixes 90% of #25047 ] * e-folder-list.c (get_folder_for_uri): shamelessly lifted from evolution-folder-selector-button.c. (create_display_string): modeled again after evolution-folder-selector-button.c, so we can give a little more context (and make the table look like the folder selector buttons.) (SPEC): add a pixbuf column, also remove the sorting behavior. (columns): add a pixbuf column and another string column (for the display string). (add_clicked): create the display string and get the proper pixbuf, and insert both. (edit_clicked): removed. (update_buttons): remove edit button handling from here. (e_folder_list_init): remove the hooking up of button-edit's "clicked" signal. (e_folder_list_construct): get a reference to the storage registry so we can look up folders. (e_folder_list_set_items): analogous change to add_clicked - get the display string and pixbuf and insert them. * glade/e-folder-list.glade: remove the edit button. * glade/e-shell-config-default-folders.glade: remove the frame/vbox, since we embed it in a notebook and the tab has the title already. * e-shell-config.c (config_control_factory_cb): the only config control we deal with here now is the folder settings control. * e-shell-config-default-folders.c (e_shell_config_default_folders_create_widget): rename e_shell_config_default_folders_create_control to this, return the widget, and take the config control to use as an arg. * e-shell-config-offline.c (e_shell_config_offline_create_widget): make an analogous change here as with default_folders_create_widget. * e-shell-config-default-folders.h (e_shell_config_default_folders_create_widget): track change to prototype. * e-shell-config-offline.h (e_shell_config_offline_create_widget): same. * GNOME_Evolution_Shell.oaf.in: remove the DefaultFolders and OfflineFolders controls and add a FolderSettings_Control. * Makefile.am (evolution_SOURCES): add e-shell-config-folder-settings.[ch] and e-shell-config-autocompletion.[ch]. * e-shell-config-folder-settings.[ch]: new files, embed (after a fashion) the default folder, offline, and autocompletion UI's in a notebook. * e-shell-config-autocompletion.[ch]: Basically copy over and shell-ize the addressbook autocompletion config control so it can be embedded more easily with the other folder settings. svn path=/trunk/; revision=17000
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 275d9a54c1..95854f4f5a 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -152,10 +152,14 @@ evolution_SOURCES = \
e-shell-about-box.h \
e-shell-config.c \
e-shell-config.h \
+ e-shell-config-autocompletion.c \
+ e-shell-config-autocompletion.h \
e-shell-config-offline.c \
e-shell-config-offline.h \
e-shell-config-default-folders.c \
e-shell-config-default-folders.h \
+ e-shell-config-folder-settings.c \
+ e-shell-config-folder-settings.h \
e-shell-constants.h \
e-shell-folder-commands.c \
e-shell-folder-commands.h \