aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorChristopher James Lahey <clahey@ximian.com>2001-05-26 02:35:40 +0800
committerChris Lahey <clahey@src.gnome.org>2001-05-26 02:35:40 +0800
commit9288ec2e2c8ae08e2fd27f6a55e45440156344c0 (patch)
tree135f4ba0b00c992492b8263e2cebae35ab820784 /shell/Makefile.am
parentbf8462bc71a2cb37a6fbd52e48ea49956e5250ca (diff)
downloadgsoc2013-evolution-9288ec2e2c8ae08e2fd27f6a55e45440156344c0.tar
gsoc2013-evolution-9288ec2e2c8ae08e2fd27f6a55e45440156344c0.tar.gz
gsoc2013-evolution-9288ec2e2c8ae08e2fd27f6a55e45440156344c0.tar.bz2
gsoc2013-evolution-9288ec2e2c8ae08e2fd27f6a55e45440156344c0.tar.lz
gsoc2013-evolution-9288ec2e2c8ae08e2fd27f6a55e45440156344c0.tar.xz
gsoc2013-evolution-9288ec2e2c8ae08e2fd27f6a55e45440156344c0.tar.zst
gsoc2013-evolution-9288ec2e2c8ae08e2fd27f6a55e45440156344c0.zip
Added ETSPECDIR. Added e-storage-set-view.etspec to get installed.
2001-05-21 Christopher James Lahey <clahey@ximian.com> * Makefile.am (INCLUDES): Added ETSPECDIR. Added e-storage-set-view.etspec to get installed. * e-local-storage.c (remove_folder_directory): Commented out this function since it is unused. * e-shell-folder-commands.c (folder_selection_dialog_folder_selected_callback), e-shell-view.c (update_offline_toggle_status): Fixed warnings here by adding a return; after the g_assert_not_reached();. * e-shell-importer.c (start_import): Got rid of real_folderpath here and just reused folderpath (It was causing uninitialized variable warnings.) * e-shell.c (impl_Shell_getLocalStorage): Use bonobo_object_dup_ref here. It makes things simpler. * e-storage-set-view.c: Removed ETREE_SPEC since it's no longer needed. (convert_corba_drag_action_set_to_gdk, folder_context_menu_activate_cb, remove_cb, folder_context_menu_remove_cb): Commented out these functions since they're unused. (new_storage_cb, new_folder_cb, insert_folders, insert_storages): Don't bother using insert_id here since it no longer does anything. (new_storage_cb, removed_storage_cb, removed_folder_cb): Don't free the data returned from e_tree_memory_node_remove. (e_storage_set_view_construct): Set the destroy func here so that memory will automatically get freed when nodes are destroyed. g_strdup the root node string here. Use e_tree_construct_from_spec_file here to use an external file. (e_storage_set_view_set_show_folders): g_strdup the root node string here. * e-storage-set-view.etspec: New etspec file. * evolution-shell-component-client.c (free_ShellComponentListener_servant): Added a prototype here. svn path=/trunk/; revision=9989
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 0f2e1731c2..8cd1c9c3ef 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -10,6 +10,7 @@ INCLUDES = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_DATADIR=\""$(datadir)"\" \
-DEVOLUTION_GLADEDIR=\"$(datadir)/evolution/glade\" \
+ -DEVOLUTION_ETSPECDIR=\"$(datadir)/evolution/etspec\" \
-DG_LOG_DOMAIN=\"evolution-shell\"
# CORBA stuff
@@ -150,9 +151,12 @@ oafdir = $(datadir)/oaf
oaf_in_files = GNOME_Evolution_Shell.oaf.in
oaf_DATA = $(oaf_in_files:.oaf.in=.oaf)
+etspecdir = $(datadir)/evolution/etspec/
+etspec_DATA = e-storage-set-view.etspec
+
@XML_I18N_MERGE_OAF_RULE@
-EXTRA_DIST = $(IDLS) $(oaf_in_files) $(oaf_DATA)
+EXTRA_DIST = $(IDLS) $(oaf_in_files) $(oaf_DATA) $(etspec_DATA)
# Purify support