aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-11-08 01:44:44 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-11-08 03:01:46 +0800
commit86ecfc50539ddef82205551c11a6a13b135bbab4 (patch)
treecc25ca582935748885a23d665a1d9e1bbc1d4d9c /shell/Makefile.am
parentaa66a17e401d73cbe394ed7f99bf73350e9b938b (diff)
downloadgsoc2013-evolution-86ecfc50539ddef82205551c11a6a13b135bbab4.tar
gsoc2013-evolution-86ecfc50539ddef82205551c11a6a13b135bbab4.tar.gz
gsoc2013-evolution-86ecfc50539ddef82205551c11a6a13b135bbab4.tar.bz2
gsoc2013-evolution-86ecfc50539ddef82205551c11a6a13b135bbab4.tar.lz
gsoc2013-evolution-86ecfc50539ddef82205551c11a6a13b135bbab4.tar.xz
gsoc2013-evolution-86ecfc50539ddef82205551c11a6a13b135bbab4.tar.zst
gsoc2013-evolution-86ecfc50539ddef82205551c11a6a13b135bbab4.zip
Convert some "Save As" actions to run asynchronously.
This introduces e-shell-utils for miscellaneous utility functions that integrate with the shell or shell settings. First function is e_shell_run_save_dialog(), which automatically remembers the selected folder in the file chooser dialog. Also, kill some redundant save dialog functions, as well as some write-this-string-to-disk functions that block.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index d8eea3c5e3..608ecd314d 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -26,6 +26,7 @@ eshellinclude_HEADERS = \
e-shell-sidebar.h \
e-shell-switcher.h \
e-shell-taskbar.h \
+ e-shell-utils.h \
e-shell-view.h \
e-shell-window.h \
e-shell-window-actions.h \
@@ -59,7 +60,7 @@ libeshell_la_CPPFLAGS = \
libeshell_la_SOURCES = \
$(NM_SUPPORT_FILES) \
- $(IDL_GENERATED) \
+ $(eshellinclude_HEADERS) \
e-shell.c \
e-shell-backend.c \
e-shell-content.c \
@@ -67,11 +68,11 @@ libeshell_la_SOURCES = \
e-shell-sidebar.c \
e-shell-switcher.c \
e-shell-taskbar.c \
+ e-shell-utils.c \
e-shell-view.c \
e-shell-window.c \
e-shell-window-private.c \
e-shell-window-private.h \
- $(eshellinclude_HEADERS) \
e-shell-migrate.c \
e-shell-migrate.h \
e-shell-window-actions.c \