aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorbertrand <bertrand@helixcode.com>2000-03-12 23:17:01 +0800
committerBertrand Guiheneuf <bertrand@src.gnome.org>2000-03-12 23:17:01 +0800
commit5adb1dedf6e2fedd68edecc67f8badb28994dce7 (patch)
tree7cb2cec0e80c9521287661870618ee35549c1451 /shell/Makefile.am
parent6e515d204a3477cabe2d5dd934ee45406c528ab5 (diff)
downloadgsoc2013-evolution-5adb1dedf6e2fedd68edecc67f8badb28994dce7.tar
gsoc2013-evolution-5adb1dedf6e2fedd68edecc67f8badb28994dce7.tar.gz
gsoc2013-evolution-5adb1dedf6e2fedd68edecc67f8badb28994dce7.tar.bz2
gsoc2013-evolution-5adb1dedf6e2fedd68edecc67f8badb28994dce7.tar.lz
gsoc2013-evolution-5adb1dedf6e2fedd68edecc67f8badb28994dce7.tar.xz
gsoc2013-evolution-5adb1dedf6e2fedd68edecc67f8badb28994dce7.tar.zst
gsoc2013-evolution-5adb1dedf6e2fedd68edecc67f8badb28994dce7.zip
Implementation of the service repository interface as a bonobo object.
2000-03-12 bertrand <bertrand@helixcode.com> * shell/evolution-service-repository.c: * shell/evolution-service-repository.h: Implementation of the service repository interface as a bonobo object. * shell/evolution-service-repository.idl: new file. Contains the definition for the service repository interface. * shell/Shell.idl: move the shell related stuff here svn path=/trunk/; revision=2103
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 1ad4872aad..f7d4476eac 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -32,11 +32,14 @@ evolution_SOURCES = \
e-shell-view-menu.c \
e-shell-view-menu.h \
e-shortcut.c \
- e-shortcut.h
+ e-shortcut.h \
+ evolution-service-repository.c \
+ evolution-service-repository.h
+
Evolution-impl.o: Evolution.h
-$(EVOLUTION_CORBA_GENERATED): Evolution.idl
+$(EVOLUTION_CORBA_GENERATED): Evolution.idl evolution-service-repository.idl
orbit-idl -I`$(GNOME_CONFIG) --datadir`/idl -I$(srcdir) $(srcdir)/Evolution.idl
evolution_LDADD = \
@@ -45,4 +48,7 @@ evolution_LDADD = \
../e-util/libeutil.la \
$(BONOBO_GNOME_LIBS)
-EXTRA_DIST = Evolution.idl
+EXTRA_DIST = Evolution.idl \
+ Shell.idl \
+ evolution-service-repository.idl
+