aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-12-28 03:10:15 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-12-28 03:32:39 +0800
commit59bd81691def7f7f8c0ead2edaacd374b6791067 (patch)
treee09951e7f35561f573fc56a50f42c706ac25aae5 /shell/Makefile.am
parent6a074300e533a82fb1a09b470724e54b155f8cd5 (diff)
downloadgsoc2013-evolution-59bd81691def7f7f8c0ead2edaacd374b6791067.tar
gsoc2013-evolution-59bd81691def7f7f8c0ead2edaacd374b6791067.tar.gz
gsoc2013-evolution-59bd81691def7f7f8c0ead2edaacd374b6791067.tar.bz2
gsoc2013-evolution-59bd81691def7f7f8c0ead2edaacd374b6791067.tar.lz
gsoc2013-evolution-59bd81691def7f7f8c0ead2edaacd374b6791067.tar.xz
gsoc2013-evolution-59bd81691def7f7f8c0ead2edaacd374b6791067.tar.zst
gsoc2013-evolution-59bd81691def7f7f8c0ead2edaacd374b6791067.zip
Compiler and linker flag cleanups.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 876b945f8f..b941ee2753 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -56,6 +56,7 @@ libeshell_la_CPPFLAGS = \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(datadir)"\" \
-DG_LOG_DOMAIN=\"evolution-shell\" \
+ $(GNOME_PLATFORM_CFLAGS) \
$(TZDIALOG_CFLAGS) \
$(SHELL_CFLAGS)
@@ -138,7 +139,8 @@ evolution_LDADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/filter/libfilter.la \
$(TZDIALOG_LIBS) \
- $(SHELL_LIBS) \
+ $(SHELL_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
$(EVOLUTIONICONRC)
if OS_WIN32