aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@src.gnome.org>2007-06-03 22:50:35 +0800
committerSrinivasa Ragavan <sragavan@src.gnome.org>2007-06-03 22:50:35 +0800
commit54a9260f696f5c7462f40af8f838d723ba3abeb5 (patch)
treeab87ece78582288b7dabf6635fe3f393fd042c4d /shell/Makefile.am
parentb484ae1c53ce5e8075eefe907cffbcb936106397 (diff)
downloadgsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.gz
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.bz2
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.lz
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.xz
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.tar.zst
gsoc2013-evolution-54a9260f696f5c7462f40af8f838d723ba3abeb5.zip
Fix for version removal from installed files.
svn path=/trunk/; revision=33646
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am24
1 files changed, 8 insertions, 16 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 4b671f52aa..8eef0ef0df 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -96,10 +96,10 @@ eshellinclude_HEADERS = \
es-event.h \
es-menu.h
-libeshell_la_SOURCES = \
+libeshell_la_SOURCES = \
$(IDL_GENERATED) \
$(MARSHAL_GENERATED) \
- e-component-view.c \
+ e-component-view.c \
evolution-component.c \
evolution-listener.c \
e-shell-utils.c \
@@ -176,14 +176,14 @@ libevolution_test_la_LDFLAGS = -avoid-version -module $(NO_UNDEFINED)
if ENABLE_TEST_COMPONENT
testserver_in_files = GNOME_Evolution_Test.server.in.in
-testserver_DATA = $(testserver_in_files:.server.in.in=_$(BASE_VERSION).server)
+testserver_DATA = $(testserver_in_files:.server.in.in=.server)
testserverdir = $(serverdir)
endif
# Misc stuff
server_in_files = GNOME_Evolution_Shell.server.in.in
-server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)
+server_DATA = $(server_in_files:.server.in.in=.server)
@EVO_SERVER_RULE@
@INTLTOOL_SERVER_RULE@
@@ -198,10 +198,8 @@ glade_DATA = \
# GConf schemas
schemadir = $(GCONF_SCHEMA_FILE_DIR)
-schema_in_files = apps_evolution_shell.schemas.in.in
-schema_DATA = $(schema_in_files:.schemas.in.in=-$(BASE_VERSION).schemas)
-%-$(BASE_VERSION).schemas.in: %.schemas.in.in
- cp $< $@
+schema_in_files = apps_evolution_shell.schemas.in
+schema_DATA = $(schema_in_files:.schemas.in=.schemas)
@INTLTOOL_SCHEMAS_RULE@
@@ -227,16 +225,10 @@ endif
install-evolution:
$(mkinstalldirs) $(DESTDIR)$(bindir)
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution$(EXEEXT) $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)$(EXEEXT)
-if DEFAULT_BINARY
- cd $(DESTDIR)$(bindir) && rm -f evolution$(EXEEXT) && $(LN_S) evolution-$(BASE_VERSION)$(EXEEXT) evolution$(EXEEXT)
-endif
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) evolution$(EXEEXT) $(DESTDIR)$(bindir)/evolution$(EXEEXT)
uninstall-evolution:
- $(LIBTOOL) --mode=uninstall rm -rf $(DESTDIR)$(bindir)/evolution-$(BASE_VERSION)$(EXEEXT)
-if DEFAULT_BINARY
- rm -f $(DESTDIR)$(bindir)/evolution$(EXEEXT)
-endif
+ $(LIBTOOL) --mode=uninstall rm -rf $(DESTDIR)$(bindir)/evolution$(EXEEXT)
if HAVE_DTAPPINTEGRATE