aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-06-13 02:28:07 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-06-13 02:28:07 +0800
commit51d0fc6863be998af5056605281cc0ebc2abfe00 (patch)
treeca9410d6729e2b3d989f0fbbc069c2563a634739 /shell/Makefile.am
parent077116eac4cbfd5f06c44c8f5634469eab3130e6 (diff)
downloadgsoc2013-evolution-51d0fc6863be998af5056605281cc0ebc2abfe00.tar
gsoc2013-evolution-51d0fc6863be998af5056605281cc0ebc2abfe00.tar.gz
gsoc2013-evolution-51d0fc6863be998af5056605281cc0ebc2abfe00.tar.bz2
gsoc2013-evolution-51d0fc6863be998af5056605281cc0ebc2abfe00.tar.lz
gsoc2013-evolution-51d0fc6863be998af5056605281cc0ebc2abfe00.tar.xz
gsoc2013-evolution-51d0fc6863be998af5056605281cc0ebc2abfe00.tar.zst
gsoc2013-evolution-51d0fc6863be998af5056605281cc0ebc2abfe00.zip
Bug 603468 - Improve handling of --quit option
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index 567059e0f1..2f044e420e 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -6,15 +6,23 @@ endif
bin_PROGRAMS = evolution
# Shell library
-privsolib_LTLIBRARIES = libeshell.la
+privsolib_LTLIBRARIES = libeshell.la
eshellincludedir = $(privincludedir)/shell
+include $(top_srcdir)/glib-gen.mak
+glib_enum_headers=e-shell.h
+glib_enum_define=E_SHELL
+glib_enum_prefix=e_shell
+
+ENUM_GENERATED = e-shell-enumtypes.h e-shell-enumtypes.c
+
eshellinclude_HEADERS = \
e-shell.h \
e-shell-backend.h \
e-shell-common.h \
e-shell-content.h \
+ e-shell-enumtypes.h \
e-shell-searchbar.h \
e-shell-settings.h \
e-shell-sidebar.h \
@@ -58,6 +66,7 @@ libeshell_la_SOURCES = \
e-shell.c \
e-shell-backend.c \
e-shell-content.c \
+ e-shell-enumtypes.c \
e-shell-meego.c \
e-shell-meego.h \
e-shell-searchbar.c \
@@ -217,7 +226,7 @@ evolution.pure: evolution
endif
-BUILT_SOURCES = $(error_DATA)
+BUILT_SOURCES = $(error_DATA) $(ENUM_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
DISTCLEANFILES = $(schema_DATA)