aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2004-05-12 11:33:51 +0800
committerMichael Zucci <zucchi@src.gnome.org>2004-05-12 11:33:51 +0800
commit2cf63ca4bace1165d5f0385f4d0dbcce83269775 (patch)
tree3c68cb544d8d2bc4f813324ed65a12db349cbcb3 /shell/Makefile.am
parentc31e31f1fd019ac4297d840761026e64ea6a0adf (diff)
downloadgsoc2013-evolution-2cf63ca4bace1165d5f0385f4d0dbcce83269775.tar
gsoc2013-evolution-2cf63ca4bace1165d5f0385f4d0dbcce83269775.tar.gz
gsoc2013-evolution-2cf63ca4bace1165d5f0385f4d0dbcce83269775.tar.bz2
gsoc2013-evolution-2cf63ca4bace1165d5f0385f4d0dbcce83269775.tar.lz
gsoc2013-evolution-2cf63ca4bace1165d5f0385f4d0dbcce83269775.tar.xz
gsoc2013-evolution-2cf63ca4bace1165d5f0385f4d0dbcce83269775.tar.zst
gsoc2013-evolution-2cf63ca4bace1165d5f0385f4d0dbcce83269775.zip
add for translators.
2004-05-12 Not Zed <NotZed@Ximian.com> * shell-errors.xml.h: add for translators. 2004-05-11 Not Zed <NotZed@Ximian.com> * shell-errors.xml: Shell errors. * e-shell.c (e_shell_attempt_upgrade): handle exceptions better. allow the user to keep going or abort. stop as soon as something fails. Related to #53083. (attempt_upgrade): abort and quit if the subcall failed. it will display an appropriate error box. (attempt_upgrade): abort if we don't have enough space. #57290. * Evolution-Component.idl (upgradeFromVersion): remove the return code, use exceptions to indicate failure. svn path=/trunk/; revision=25869
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index e8a459b4d5..4a4715a20e 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -198,6 +198,12 @@ server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)
@EVO_SERVER_RULE@
@INTLTOOL_SERVER_RULE@
+error_DATA = shell-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
+errordir = $(privdatadir)/errors
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
+
etspec_DATA = e-storage-set-view.etspec
icons = \
@@ -252,6 +258,7 @@ EXTRA_DIST = \
$(IDLS) \
$(server_in_files) \
GNOME_Evolution_Test.server.in.in \
+ $(error_DATA) $(error_i18n) \
$(etspec_DATA) \
$(schema_DATA) \
$(icons) \
@@ -273,7 +280,7 @@ evolution.pure: evolution
endif
-BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(testserver_DATA) $(DATASERVER_IDL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(testserver_DATA) $(DATASERVER_IDL_GENERATED) $(error_i18n)
CLEANFILES = $(BUILT_SOURCES)
dist-hook: