aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@src.gnome.org>2003-11-07 13:52:24 +0800
committerJP Rosevear <jpr@src.gnome.org>2003-11-07 13:52:24 +0800
commit200606f92810d3de322e5ee96f8326e1a656f8bb (patch)
treeda0dc27f5311128dcb6e7eb6400931e45743372e /shell/Makefile.am
parente5472b4cc9a4bb80b89437a16f8b77943ea35555 (diff)
downloadgsoc2013-evolution-200606f92810d3de322e5ee96f8326e1a656f8bb.tar
gsoc2013-evolution-200606f92810d3de322e5ee96f8326e1a656f8bb.tar.gz
gsoc2013-evolution-200606f92810d3de322e5ee96f8326e1a656f8bb.tar.bz2
gsoc2013-evolution-200606f92810d3de322e5ee96f8326e1a656f8bb.tar.lz
gsoc2013-evolution-200606f92810d3de322e5ee96f8326e1a656f8bb.tar.xz
gsoc2013-evolution-200606f92810d3de322e5ee96f8326e1a656f8bb.tar.zst
gsoc2013-evolution-200606f92810d3de322e5ee96f8326e1a656f8bb.zip
Various changes to merge in evolution-data-server reliance.
svn path=/trunk/; revision=23206
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am33
1 files changed, 15 insertions, 18 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index ac0e2d75d9..52cb69d8e2 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -19,6 +19,7 @@ INCLUDES = \
-DDATADIR=\""$(datadir)"\" \
-DLIBDIR=\""$(datadir)"\" \
-DG_LOG_DOMAIN=\"evolution-shell\" \
+ $(TZDIALOG_CFLAGS) \
$(SHELL_CFLAGS)
noinst_PROGRAMS = evolution evolution-test-component
@@ -79,25 +80,21 @@ $(SELECT_NAMES_IDL_GENERATED_H): $(SELECT_NAMES_IDL)
$(SELECT_NAMES_IDL_GENERATED_C): $(SELECT_NAMES_IDL_GENERATED_H)
-# Wombat CORBA stuff
+# Data Server CORBA stuff
+DATASERVER_IDL_GENERATED_H = \
+ Evolution-DataServer.h
-WOMBAT_IDL = \
- $(top_srcdir)/wombat/Evolution-Wombat.idl
+DATASERVER_IDL_GENERATED_C = \
+ Evolution-DataServer-common.c \
+ Evolution-DataServer-skels.c \
+ Evolution-DataServer-stubs.c
-WOMBAT_IDL_GENERATED_H = \
- Evolution-Wombat.h
+DATASERVER_IDL_GENERATED = $(DATASERVER_IDL_GENERATED_C) $(DATASERVER_IDL_GENERATED_H)
-WOMBAT_IDL_GENERATED_C = \
- Evolution-Wombat-common.c \
- Evolution-Wombat-skels.c \
- Evolution-Wombat-stubs.c
+$(DATASERVER_IDL_GENERATED_H): $(DATASERVER_IDL)
+ $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(DATASERVER_IDL)
-WOMBAT_IDL_GENERATED = $(WOMBAT_IDL_GENERATED_C) $(WOMBAT_IDL_GENERATED_H)
-
-$(WOMBAT_IDL_GENERATED_H): $(WOMBAT_IDL)
- $(ORBIT_IDL) -I $(srcdir) $(IDL_INCLUDES) $(WOMBAT_IDL)
-
-$(WOMBAT_IDL_GENERATED_C): $(WOMBAT_IDL_GENERATED_H)
+$(DATASERVER_IDL_GENERATED_C): $(DATASERVER_IDL_GENERATED_H)
# IDL install
@@ -182,7 +179,7 @@ libeshell_la_LIBADD = \
evolution_SOURCES = \
$(SELECT_NAMES_IDL_GENERATED) \
- $(WOMBAT_IDL_GENERATED) \
+ $(DATASERVER_IDL_GENERATED) \
e-component-registry.c \
e-component-registry.h \
e-config-upgrade.c \
@@ -232,7 +229,7 @@ evolution_LDADD = \
$(top_builddir)/widgets/e-timezone-dialog/libetimezonedialog.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
$(top_builddir)/e-util/libeutil.la \
- $(top_builddir)/libical/src/libical/libical-evolution.la \
+ $(TZDIALOG_LIBS) \
$(SHELL_LIBS)
# Test component
@@ -327,7 +324,7 @@ evolution.pure: evolution
endif
-BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(WOMBAT_IDL_GENERATED)
+BUILT_SOURCES = $(IDL_GENERATED) $(SELECT_NAMES_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(DATASERVER_IDL_GENERATED)
CLEANFILES = $(BUILT_SOURCES)
dist-hook: