aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2005-08-18 12:35:31 +0800
committerMichael Zucci <zucchi@src.gnome.org>2005-08-18 12:35:31 +0800
commit1bcb9b46314a8a5fab19293024c616712a27f1ee (patch)
tree9cdb35e2ace0c2c891200b44f8c9dc718e5e150d /shell/Makefile.am
parent5f02035e617747b865cf402953b01deb9cc07bf9 (diff)
downloadgsoc2013-evolution-1bcb9b46314a8a5fab19293024c616712a27f1ee.tar
gsoc2013-evolution-1bcb9b46314a8a5fab19293024c616712a27f1ee.tar.gz
gsoc2013-evolution-1bcb9b46314a8a5fab19293024c616712a27f1ee.tar.bz2
gsoc2013-evolution-1bcb9b46314a8a5fab19293024c616712a27f1ee.tar.lz
gsoc2013-evolution-1bcb9b46314a8a5fab19293024c616712a27f1ee.tar.xz
gsoc2013-evolution-1bcb9b46314a8a5fab19293024c616712a27f1ee.tar.zst
gsoc2013-evolution-1bcb9b46314a8a5fab19293024c616712a27f1ee.zip
fix warning. (impl_Shell_findComponent): fix signature for warning.
2005-08-17 Not Zed <NotZed@Ximian.com> * e-shell.c (impl_Shell_handleURI): fix warning. (impl_Shell_findComponent): fix signature for warning. 2005-08-16 Not Zed <NotZed@Ximian.com> ** See bug #312668. * e-shell.c (set_line_status, set_line_status_complete) (set_line_status_finished): new code to set componetns on/offline. (e_shell_go_online, e_shell_go_offline): use new interface. (offline_procedure_started_cb, offline_procedure_finished_cb): removed. (impl_dispose): cleanup line status listener. (e_shell_init): setup line status listener. * evolution-listener.[ch]: skeleton listener object for new setlinestatus call. * Evolution-Offline.idl, e-shell-offline-handler.[ch]: killed. We just add a single interface on EvolutionComponent now, much simpler. svn path=/trunk/; revision=30154
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index fcc4cec537..944c25cd7c 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -27,7 +27,6 @@ noinst_PROGRAMS = evolution
IDLS = \
Evolution-ConfigControl.idl \
Evolution-Component.idl \
- Evolution-Offline.idl \
Evolution-Shell.idl \
Evolution.idl
@@ -84,15 +83,16 @@ eshellinclude_HEADERS = \
e-user-creatable-items-handler.h \
evolution-config-control.h \
evolution-component.h \
+ evolution-listener.h \
evolution-shell-component-utils.h \
es-event.h \
es-menu.h
-
libeshell_la_SOURCES = \
$(IDL_GENERATED) \
$(MARSHAL_GENERATED) \
evolution-component.c \
+ evolution-listener.c \
e-shell-utils.c \
e-user-creatable-items-handler.c \
evolution-config-control.c \
@@ -123,8 +123,6 @@ evolution_SOURCES = \
e-shell-folder-title-bar.h \
e-shell-importer.c \
e-shell-importer.h \
- e-shell-offline-handler.c \
- e-shell-offline-handler.h \
e-shell-settings-dialog.c \
e-shell-settings-dialog.h \
e-shell-window-commands.c \