aboutsummaryrefslogtreecommitdiffstats
path: root/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-03-25 07:28:50 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-03-25 08:06:49 +0800
commit1723ee09122a8e137e78ed301f2706eefb281adf (patch)
tree32839933e0894443b4091a63748ddcbce30987a4 /shell/Makefile.am
parent4a32f924be0343bdf3afae9f14482ab651e8ccf8 (diff)
downloadgsoc2013-evolution-1723ee09122a8e137e78ed301f2706eefb281adf.tar
gsoc2013-evolution-1723ee09122a8e137e78ed301f2706eefb281adf.tar.gz
gsoc2013-evolution-1723ee09122a8e137e78ed301f2706eefb281adf.tar.bz2
gsoc2013-evolution-1723ee09122a8e137e78ed301f2706eefb281adf.tar.lz
gsoc2013-evolution-1723ee09122a8e137e78ed301f2706eefb281adf.tar.xz
gsoc2013-evolution-1723ee09122a8e137e78ed301f2706eefb281adf.tar.zst
gsoc2013-evolution-1723ee09122a8e137e78ed301f2706eefb281adf.zip
Fix mbox-to-Maildir conversion... again.
Commit ee5671fc fixed mbox-to-Maildir conversion for users upgrading from Evolution 2.32, who had already migrated to XDG Base Directories. But turns out, mbox-to-Maildir conversion was still broken for users coming from Evolution 2.30 or earlier because the logic to move files into XDG Base Directories was running *after* the conversion routine. So the conversion routine found nothing to convert, and users were left with a broken "On This Computer" mail store. This commit runs the XDG Base Directory migration first on startup, followed by the mbox-to-Maildir conversion.
Diffstat (limited to 'shell/Makefile.am')
-rw-r--r--shell/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/shell/Makefile.am b/shell/Makefile.am
index bd2fe53dbd..8961444800 100644
--- a/shell/Makefile.am
+++ b/shell/Makefile.am
@@ -123,7 +123,8 @@ evolution_CPPFLAGS = \
evolution_SOURCES = \
main.c \
- e-convert-local-mail.c
+ e-convert-local-mail.c \
+ e-migrate-base-dirs.c
evolution_LDADD = \
libeshell.la \