aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/publish-calendar/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-10-05 09:32:41 +0800
committerMatthew Barnes <mbarnes@redhat.com>2011-10-05 10:27:14 +0800
commit1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba (patch)
tree8b3d99bcac99c3a3edbb2939ea0226c187a39eb4 /plugins/publish-calendar/Makefile.am
parent273b10a5baebd97bea4aeb1dae158f93ce93eb72 (diff)
downloadgsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.gz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.bz2
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.lz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.xz
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.tar.zst
gsoc2013-evolution-1f38f4d92ca8eb97381b2c9a7022830a6d4bcaba.zip
Simplify library dependency flags.
We have a confusing array of nearly-identical CFLAGS/LIBS definitions in configure.ac. Time to simplify. Instead let's just have one definition that includes all the libraries provided by Evolution-Data-Server (incl. Camel). That, in combination with GNOME_PLATFORM, gives us most of what we need for compliation and linking, and we can sprinkle definitions for additional library dependencies in Makefile.am's as needed.
Diffstat (limited to 'plugins/publish-calendar/Makefile.am')
-rw-r--r--plugins/publish-calendar/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/plugins/publish-calendar/Makefile.am b/plugins/publish-calendar/Makefile.am
index 94c29f11b5..b19dc8d1a4 100644
--- a/plugins/publish-calendar/Makefile.am
+++ b/plugins/publish-calendar/Makefile.am
@@ -13,9 +13,9 @@ liborg_gnome_publish_calendar_la_CPPFLAGS = \
-I$(top_srcdir) \
-I$(top_srcdir)/widgets \
-I$(top_builddir)/shell \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
$(GNOME_PLATFORM_CFLAGS) \
- $(E_UTIL_CFLAGS) \
- $(EVOLUTION_CALENDAR_CFLAGS) \
+ $(LIBNOTIFY_CFLAGS) \
-DEVOLUTION_PLUGINDIR="\"$(plugindir)\"" \
-DEVOLUTION_UIDIR=\""$(uidir)"\"
@@ -36,9 +36,9 @@ liborg_gnome_publish_calendar_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/shell/libeshell.la \
$(top_builddir)/calendar/gui/libevolution-calendar.la \
- $(E_UTIL_LIBS) \
- $(EVOLUTION_CALENDAR_LIBS) \
- $(GNOME_PLATFORM_LIBS)
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(LIBNOTIFY_LIBS)
EXTRA_DIST = \
org-gnome-publish-calendar.eplug.xml \