aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/mail-notification/Makefile.am
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@novell.com>2008-01-09 23:10:48 +0800
committerSrinivasa Ragavan <sragavan@src.gnome.org>2008-01-09 23:10:48 +0800
commit77aa984d1b67e06cf757510c80da2e3e51fc9ec1 (patch)
treec82df11e60eb045b207379fa5180328774ba58af /plugins/mail-notification/Makefile.am
parent959b1463cb7e51bf68cfa8d8654af006ed2ffbcf (diff)
downloadgsoc2013-evolution-77aa984d1b67e06cf757510c80da2e3e51fc9ec1.tar
gsoc2013-evolution-77aa984d1b67e06cf757510c80da2e3e51fc9ec1.tar.gz
gsoc2013-evolution-77aa984d1b67e06cf757510c80da2e3e51fc9ec1.tar.bz2
gsoc2013-evolution-77aa984d1b67e06cf757510c80da2e3e51fc9ec1.tar.lz
gsoc2013-evolution-77aa984d1b67e06cf757510c80da2e3e51fc9ec1.tar.xz
gsoc2013-evolution-77aa984d1b67e06cf757510c80da2e3e51fc9ec1.tar.zst
gsoc2013-evolution-77aa984d1b67e06cf757510c80da2e3e51fc9ec1.zip
** Fix for bug #492702
2008-01-09 Srinivasa Ragavan <sragavan@novell.com> ** Fix for bug #492702 * configure.in: Just disable the dbus message part of mail notification if dbus isn't there. Also remove new-mail-notify plugin. svn path=/trunk/; revision=34784
Diffstat (limited to 'plugins/mail-notification/Makefile.am')
-rw-r--r--plugins/mail-notification/Makefile.am18
1 files changed, 12 insertions, 6 deletions
diff --git a/plugins/mail-notification/Makefile.am b/plugins/mail-notification/Makefile.am
index 8b93fe3e3c..38b4f051f7 100644
--- a/plugins/mail-notification/Makefile.am
+++ b/plugins/mail-notification/Makefile.am
@@ -1,10 +1,13 @@
INCLUDES = \
-I$(top_srcdir) \
- -DDBUS_API_SUBJECT_TO_CHANGE=1 \
- -DDBUS_VERSION=$(DBUS_VERSION) \
$(EVOLUTION_MAIL_CFLAGS) \
- $(LIBNOTIFY_CFLAGS) \
- $(NMN_CFLAGS)
+ $(LIBNOTIFY_CFLAGS)
+
+if ENABLE_DBUS
+INCLUDES += -DDBUS_API_SUBJECT_TO_CHANGE=1 \
+ -DDBUS_VERSION=$(DBUS_VERSION) \
+ $(NMN_CFLAGS)
+endif
@EVO_PLUGIN_RULE@
@@ -14,8 +17,11 @@ plugin_LTLIBRARIES = liborg-gnome-mail-notification.la
liborg_gnome_mail_notification_la_SOURCES = mail-notification.c
liborg_gnome_mail_notification_la_LDFLAGS = \
-module -avoid-version \
- $(LIBNOTIFY_LIBS) \
- $(NMN_LIBS)
+ $(LIBNOTIFY_LIBS)
+
+if ENABLE_DBUS
+liborg_gnome_mail_notification_la_LDFLAGS += $(NMN_LIBS)
+endif
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_in_files = apps-evolution-mail-notification.schemas.in