aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/email-custom-header/Makefile.am
diff options
context:
space:
mode:
authorAkhil Laddha <lakhil@src.gnome.org>2008-05-19 12:19:22 +0800
committerAkhil Laddha <lakhil@src.gnome.org>2008-05-19 12:19:22 +0800
commit7ea3da7607895f327690fdd03ec4608677ec62b4 (patch)
tree2a19dd6cc18f3293cee0093c12cbaeadda3e91f5 /plugins/email-custom-header/Makefile.am
parentbb8a109032df2f41f7dc677501f95ca4d7b9a0af (diff)
downloadgsoc2013-evolution-7ea3da7607895f327690fdd03ec4608677ec62b4.tar
gsoc2013-evolution-7ea3da7607895f327690fdd03ec4608677ec62b4.tar.gz
gsoc2013-evolution-7ea3da7607895f327690fdd03ec4608677ec62b4.tar.bz2
gsoc2013-evolution-7ea3da7607895f327690fdd03ec4608677ec62b4.tar.lz
gsoc2013-evolution-7ea3da7607895f327690fdd03ec4608677ec62b4.tar.xz
gsoc2013-evolution-7ea3da7607895f327690fdd03ec4608677ec62b4.tar.zst
gsoc2013-evolution-7ea3da7607895f327690fdd03ec4608677ec62b4.zip
Committing on behalf of Ashish Shrivastava <shashish@novell.com>
Commit for Custom header support svn path=/trunk/; revision=35510
Diffstat (limited to 'plugins/email-custom-header/Makefile.am')
-rw-r--r--plugins/email-custom-header/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/plugins/email-custom-header/Makefile.am b/plugins/email-custom-header/Makefile.am
new file mode 100644
index 0000000000..856052d6e3
--- /dev/null
+++ b/plugins/email-custom-header/Makefile.am
@@ -0,0 +1,56 @@
+INCLUDES = -I. \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_builddir)/mail \
+ -I$(top_srcdir)/camel \
+ -I$(top_builddir)/composer \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DCONNECTOR_GLADEDIR=\""$(gladedir)"\"
+
+
+@EVO_PLUGIN_RULE@
+
+plugin_DATA = \
+ org-gnome-email-custom-header.eplug
+
+plugin_LTLIBRARIES = liborg-gnome-email-custom-header.la
+
+liborg_gnome_email_custom_header_la_SOURCES = \
+ email-custom-header.c \
+ email-custom-header.h
+liborg_gnome_email_custom_header_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(NO_UNDEFINED_REQUIRED_LIBS)
+
+liborg_gnome_email_custom_header_la_LDFLAGS = -module -avoid-version $(NO_UNDEFINED)
+
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_in_files = apps_evolution_email_custom_header.schemas.in
+schema_DATA = $(schema_in_files:.schemas.in=.schemas)
+
+@INTLTOOL_SCHEMAS_RULE@
+
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schema_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p; \
+ done \
+ fi
+
+glade_DATA = \
+ org-gnome-email-custom-header.glade
+
+EXTRA_DIST = \
+ org-gnome-email-custom-header.eplug.xml \
+ $(schema_in_files)
+
+BUILT_SOURCES = \
+ org-gnome-email-custom-header.eplug \
+ $(error_i18n)
+
+CLEANFILES = $(BUILT_SOURCES)
+DISTCLEANFILES = $(schema_DATA)