aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/backup-restore/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2008-07-01 18:31:48 +0800
committerMilan Crha <mcrha@src.gnome.org>2008-07-01 18:31:48 +0800
commit51b273e5b321133422cc9c1764dbf9a9638e8187 (patch)
tree0206f3ca8df0b38d90ccd3e694f6d2289ef22b97 /plugins/backup-restore/Makefile.am
parent75edd1a5a13ad88659a641a3336c5a94d85b7f01 (diff)
downloadgsoc2013-evolution-51b273e5b321133422cc9c1764dbf9a9638e8187.tar
gsoc2013-evolution-51b273e5b321133422cc9c1764dbf9a9638e8187.tar.gz
gsoc2013-evolution-51b273e5b321133422cc9c1764dbf9a9638e8187.tar.bz2
gsoc2013-evolution-51b273e5b321133422cc9c1764dbf9a9638e8187.tar.lz
gsoc2013-evolution-51b273e5b321133422cc9c1764dbf9a9638e8187.tar.xz
gsoc2013-evolution-51b273e5b321133422cc9c1764dbf9a9638e8187.tar.zst
gsoc2013-evolution-51b273e5b321133422cc9c1764dbf9a9638e8187.zip
** Fix for bug #540274
2008-07-01 Milan Crha <mcrha@redhat.com> ** Fix for bug #540274 * Makefile.am: Link with libraries we require now. * backup.c: (rc), (s): Exchange $HOME with g_get_home_dir in commands. * backup.c: (ensure_locals), (fix_account_folder_uri), (restore): After restore walk through all account, addressbook, calendar, task and memo sources and fix the base uri if required. (One should be able to import also into different user than one where the backup was done.) svn path=/trunk/; revision=35710
Diffstat (limited to 'plugins/backup-restore/Makefile.am')
-rw-r--r--plugins/backup-restore/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/backup-restore/Makefile.am b/plugins/backup-restore/Makefile.am
index 251da8b1dd..d83b7fb2f9 100644
--- a/plugins/backup-restore/Makefile.am
+++ b/plugins/backup-restore/Makefile.am
@@ -22,7 +22,11 @@ liborg_gnome_backup_restore_la_LDFLAGS = -module -avoid-version
privlibexec_PROGRAMS = evolution-backup
evolution_backup_SOURCES = backup.c
-evolution_backup_LDADD = $(SHELL_LIBS)
+evolution_backup_LDADD = $(SHELL_LIBS) \
+ $(EVOLUTION_CALENDAR_LIBS) \
+ $(EVOLUTION_ADDRESSBOOK_LIBS) \
+ $(top_builddir)/e-util/libeutil.la
+
EXTRA_DIST = \
org-gnome-backup-restore.eplug.xml \