aboutsummaryrefslogtreecommitdiffstats
path: root/modules/text-highlight/Makefile.am
diff options
context:
space:
mode:
authorDan Vrátil <dvratil@redhat.com>2012-07-25 17:29:22 +0800
committerDan Vrátil <dvratil@redhat.com>2012-07-25 17:29:22 +0800
commit8663b54cae296883452850f3baad6d4cbc92e220 (patch)
treef895a43b817e0115a57bc639b2b6a9e40caa1193 /modules/text-highlight/Makefile.am
parentb456ff5423b9f4ffe5719e460e4b769bed28c934 (diff)
downloadgsoc2013-evolution-8663b54cae296883452850f3baad6d4cbc92e220.tar
gsoc2013-evolution-8663b54cae296883452850f3baad6d4cbc92e220.tar.gz
gsoc2013-evolution-8663b54cae296883452850f3baad6d4cbc92e220.tar.bz2
gsoc2013-evolution-8663b54cae296883452850f3baad6d4cbc92e220.tar.lz
gsoc2013-evolution-8663b54cae296883452850f3baad6d4cbc92e220.tar.xz
gsoc2013-evolution-8663b54cae296883452850f3baad6d4cbc92e220.tar.zst
gsoc2013-evolution-8663b54cae296883452850f3baad6d4cbc92e220.zip
Highlighting of text parts and source codes
This adds 'Format as' submenu to the preview pane context menu. The submenu is available only for text/plain parts or parts with a source code (we support about 40 various types). Using the 'highlight' utility, the formatter processes the part and highlights the source code it contains. (discussion in bug #680026)
Diffstat (limited to 'modules/text-highlight/Makefile.am')
-rw-r--r--modules/text-highlight/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/modules/text-highlight/Makefile.am b/modules/text-highlight/Makefile.am
index 9b27298474..8c7e639622 100644
--- a/modules/text-highlight/Makefile.am
+++ b/modules/text-highlight/Makefile.am
@@ -9,10 +9,16 @@ module_text_highlight_la_CPPFLAGS = \
$(EVOLUTION_DATA_SERVER_CFLAGS) \
$(GNOME_PLATFORM_CFLAGS)
-module_text_highlight_la_SOURCES = \
- text-highlight.c \
- text-highlight.h \
- evolution-module-text-highlight.c
+module_text_highlight_la_SOURCES = \
+ e-mail-display-popup-text-highlight.c \
+ e-mail-display-popup-text-highlight.h \
+ e-mail-formatter-text-highlight.c \
+ e-mail-formatter-text-highlight.h \
+ e-mail-parser-text-highlight.c \
+ e-mail-parser-text-highlight.h \
+ evolution-module-text-highlight.c \
+ languages.c \
+ languages.h
module_text_highlight_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
@@ -21,7 +27,7 @@ module_text_highlight_la_LIBADD = \
$(EVOLUTION_DATA_SERVER_LIBS) \
$(GNOME_PLATFORM_LIBS)
-module_text_highlight_la_LDFLAGS = \
+module_text_highlight_la_LDFLAGS = \
-avoid-version -module $(NO_UNDEFINED)
-include $(top_srcdir)/git.mk